Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

v1.2 does not build with Cabal 1.10.1.0 #12

Closed
sol opened this Issue Jun 24, 2012 · 0 comments

Comments

Projects
None yet
2 participants
Contributor

sol commented Jun 24, 2012

Cabal 1.10.1.0 has some annoying parser bug. It does not handle if-else in test sections. I'm trying to find a workaround, but the situation is somewhat complicated:

We could depend on the library instead of doing any if-else checks in test-suite sections. But this does not work; We use Hspec for the test suite, and Hspec pulls in an other version of silently. So we end up with a dependency on two different versions of the same library, and Cabal fails.

Not sure what to do yet. But currently I think the easiest way to get around this would be to not use Hspec for testing silently.

@trystan trystan closed this in a710fbe Jun 24, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment