Remove 'ghc' from build-depends. #9

Merged
merged 1 commit into from Mar 17, 2012

2 participants

@jmillikin

This packages doesn't import any modules from the 'ghc' package. It does
import 'GHC.IO.Handle', but that is provided by the 'base' package.

@jmillikin jmillikin Remove 'ghc' from build-depends.
This packages doesn't import any modules from the 'ghc' package. It does
import 'GHC.IO.Handle', but that is provided by the 'base' package.
e7e9c82
@jmillikin

Gentle ping -- this is causing me some trouble, because libraries that import both 'containers' and 'silently' fail to build on versions of GHC that have 'ghc' depend on 'containers':

$ ghc --version
The Glorious Glasgow Haskell Compilation System, version 7.2.2

$ cabal-dev install containers
Resolving dependencies...
Configuring containers-0.4.2.1...
Preprocessing library containers-0.4.2.1...
Building containers-0.4.2.1...
# ...

$ cabal-dev instal package-that-depends-on-containers-and-silently
Resolving dependencies...
cabal: dependencies conflict: ghc-7.0.4 requires containers ==0.4.2.1 however
containers-0.4.2.1 was excluded because ghc-7.0.4 requires containers
==0.4.0.0
@trystan trystan merged commit 46f2120 into trystan:master Mar 17, 2012
@trystan
Owner

Sorry I didn't get to it sooner, I've been super busy with a side project this week.

@jmillikin

Could you please release this new version to Hackage?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment