Permalink
Browse files

Remove the rewrite of UNL_Templates::$options['version'] "3.1" -> "3x…

…1" in UNL_Templates::loadDefaultConfig() so that comparisons such as

(UNL_Templates::$options['version'] == UNL_Templates::VERSION3x1) still work.
  • Loading branch information...
1 parent 7aadb55 commit b21297897d53db588e0261deefa30611ddf72743 @tsteiner committed Apr 12, 2012
Showing with 3 additions and 3 deletions.
  1. +3 −3 src/UNL/Templates.php
View
@@ -91,9 +91,9 @@ public function __construct()
*/
public static function loadDefaultConfig()
{
- self::$options['version'] = str_replace('.', 'x', self::$options['version']);
- include_once 'UNL/Templates/Version'.self::$options['version'].'.php';
- $class = 'UNL_Templates_Version'.self::$options['version'];
+ $version = str_replace('.', 'x', self::$options['version']);
+ include_once 'UNL/Templates/Version'.$version.'.php';
+ $class = 'UNL_Templates_Version'.$version;
self::$template_version = new $class();
UNL_DWT::$options = array_merge(UNL_DWT::$options, self::$template_version->getConfig());
}

0 comments on commit b212978

Please sign in to comment.