Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Bugfix #8

Merged
merged 1 commit into from Mar 8, 2013

Conversation

Projects
None yet
2 participants
Contributor

exhuma commented Mar 8, 2013

I just tried your script and it crashed because response.json is a function, and thus not iterable.

This commit fixes this issue.

Owner

ttencate commented Mar 8, 2013

This was changed in the requests package at some point. Seems better to support the new than the old, I guess.

ttencate added a commit that referenced this pull request Mar 8, 2013

Merge pull request #8 from exhuma/master
In the latest request package, response.json is a method, not a field.

@ttencate ttencate merged commit fdad3d1 into ttencate:master Mar 8, 2013

Contributor

exhuma commented Mar 8, 2013

You should probably write a setup.py (for setuptools) or requirements.txt (for pip) file. Personally, I always use pinned version numbers in those with the exact version numbers as I tested the package against.

one example from one of my projects:

install_requires = [
  'Flask==0.8',
  'sqlalchemy-migrate==0.7.2',
  'SQLAlchemy==0.7.3'
  ],

This way I am /fairly/ certain that it will install and run without too much hassle.

Owner

ttencate commented Mar 8, 2013

Yep, that's one of many things that can be improved. Feel free to send me another pull request for that ;)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment