Permalink
Browse files

configure: Remove --with-gtk flag

We only support GTK2 right now; if someone wants to do the port,
they can readd the configure flag as the last step.

https://bugzilla.gnome.org/show_bug.cgi?id=650513
  • Loading branch information...
1 parent 3a5c363 commit 48cc8cbdad70a6bf2b4e6d44d1744ab956ac830a @cgwalters cgwalters committed May 19, 2011
Showing with 6 additions and 21 deletions.
  1. +6 −21 configure.in
View
@@ -107,27 +107,12 @@ if test "x$GCC" = "xyes"; then
fi
changequote([,])dnl
-AC_MSG_CHECKING([which gtk+ version to compile against])
-AC_ARG_WITH([gtk],
- AC_HELP_STRING([--with-gtk=2.0|3.0],
- [which gtk+ version to compile against (default: 2.0)]),
- [case "$with_gtk" in
- 2.0|3.0) ;;
- *) AC_MSG_ERROR([invalid gtk+ version specified]);;
- esac],
- [with_gtk=2.0])
-AC_MSG_RESULT([$with_gtk])
-
-case "$with_gtk" in
- 2.0) GTK_API_VERSION=2.0
- GTK_MIN_VERSION=2.20.0
- CANBERRA_GTK=libcanberra-gtk
- ;;
- 3.0) GTK_API_VERSION=3.0
- GTK_MIN_VERSION=2.90.0
- CANBERRA_GTK=libcanberra-gtk3
- ;;
-esac
+dnl This used to purport to allow compilation against gtk3, but it doesn't actually
+dnl work; see https://bugzilla.gnome.org/show_bug.cgi?id=650513
+with_gtk=2.0
+GTK_API_VERSION=2.0
+GTK_MIN_VERSION=2.20.0
+CANBERRA_GTK=libcanberra-gtk
METACITY_PC_MODULES="gtk+-$GTK_API_VERSION >= $GTK_MIN_VERSION pango >= 1.2.0"
AC_SUBST(GTK_API_VERSION)

0 comments on commit 48cc8cb

Please sign in to comment.