Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

nuke jeweler, use bundler and bundler gem helper

  • Loading branch information...
commit b1e0b7c1720fa66c0f03893b9289570df7ce2ca8 1 parent c824445
@ttilley authored
View
5 .document
@@ -1,5 +0,0 @@
-README.rdoc
-lib/**/*.rb
-bin/*
-features/**/*.feature
-LICENSE
View
9 .gitignore
@@ -1,12 +1,11 @@
+*.gem
*.rbc
*.sw?
.DS_Store
+.bundle
.idea
-/*.gem
+Gemfile.lock
coverage
nbproject
-pkg
+pkg/*
rdoc
-
-# Rubinius compiled bytecode
-*.rbc
View
3  Gemfile
@@ -0,0 +1,3 @@
+source "http://rubygems.org"
+
+gemspec
View
2  LICENSE
@@ -1,4 +1,4 @@
-Copyright (c) 2009 Travis Tilley
+Copyright (c) 2011 Travis Tilley
Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
View
53 Rakefile
@@ -1,21 +1,5 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "fssm"
- gem.summary = %Q{file system state monitor}
- gem.description = %Q{file system state monitor}
- gem.email = "ttilley@gmail.com"
- gem.homepage = "http://github.com/ttilley/fssm"
- gem.authors = ["Travis Tilley"]
- gem.add_development_dependency "rspec"
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
-end
+require 'bundler'
+Bundler::GemHelper.install_tasks
require 'spec/rake/spectask'
Spec::Rake::SpecTask.new(:spec) do |spec|
@@ -24,37 +8,4 @@ Spec::Rake::SpecTask.new(:spec) do |spec|
spec.spec_opts = ['--format', 'specdoc']
end
-Spec::Rake::SpecTask.new(:rcov) do |spec|
- spec.libs << 'lib' << 'spec'
- spec.pattern = 'spec/**/*_spec.rb'
- spec.rcov = true
-end
-
-task :spec => :check_dependencies
-
-begin
- require 'reek/rake_task'
- Reek::RakeTask.new do |t|
- t.fail_on_error = true
- t.verbose = false
- t.source_files = 'lib/**/*.rb'
- end
-rescue LoadError
- task :reek do
- abort "Reek is not available. In order to run reek, you must: sudo gem install reek"
- end
-end
-
-begin
- require 'roodi'
- require 'roodi_task'
- RoodiTask.new do |t|
- t.verbose = false
- end
-rescue LoadError
- task :roodi do
- abort "Roodi is not available. In order to run roodi, you must: sudo gem install roodi"
- end
-end
-
task :default => :spec
View
5 VERSION.yml
@@ -1,5 +0,0 @@
----
-:major: 0
-:minor: 2
-:patch: 4
-:build:
View
90 fssm.gemspec
@@ -1,80 +1,24 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "fssm/version"
Gem::Specification.new do |s|
- s.name = %q{fssm}
- s.version = "0.2.4"
+ s.name = "fssm"
+ s.version = FSSM::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Travis Tilley", "Nathan Weizenbaum", "Chris Eppstein",
+ "Jonathan Castello", "Tuomas Kareinen"]
+ s.email = ["ttilley@gmail.com"]
+ s.homepage = "https://github.com/ttilley/fssm"
+ s.summary = %q{File System State Monitor}
+ s.description = %q{The File System State Monitor keeps track of the state of any number of paths and will fire events when said state changes (create/update/delete). FSSM supports using FSEvents on MacOS, Inotify on GNU/Linux, and polling anywhere else.}
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Travis Tilley"]
- s.date = %q{2011-01-15}
- s.description = %q{file system state monitor}
- s.email = %q{ttilley@gmail.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.markdown"
- ]
- s.files = [
- ".document",
- "LICENSE",
- "README.markdown",
- "Rakefile",
- "VERSION.yml",
- "example.rb",
- "fssm.gemspec",
- "lib/fssm.rb",
- "lib/fssm/backends/fsevents.rb",
- "lib/fssm/backends/inotify.rb",
- "lib/fssm/backends/polling.rb",
- "lib/fssm/backends/rbfsevent.rb",
- "lib/fssm/backends/rubycocoa/fsevents.rb",
- "lib/fssm/monitor.rb",
- "lib/fssm/path.rb",
- "lib/fssm/pathname.rb",
- "lib/fssm/state/directory.rb",
- "lib/fssm/state/file.rb",
- "lib/fssm/support.rb",
- "lib/fssm/tree.rb",
- "profile/prof-cache.rb",
- "profile/prof-fssm-pathname.html",
- "profile/prof-pathname-rubinius.rb",
- "profile/prof-pathname.rb",
- "profile/prof-plain-pathname.html",
- "profile/prof.html",
- "spec/count_down_latch.rb",
- "spec/monitor_spec.rb",
- "spec/path_spec.rb",
- "spec/root/duck/quack.txt",
- "spec/root/file.css",
- "spec/root/file.rb",
- "spec/root/file.yml",
- "spec/root/moo/cow.txt",
- "spec/spec_helper.rb"
- ]
- s.homepage = %q{http://github.com/ttilley/fssm}
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.4.2}
- s.summary = %q{file system state monitor}
- s.test_files = [
- "spec/count_down_latch.rb",
- "spec/monitor_spec.rb",
- "spec/path_spec.rb",
- "spec/root/file.rb",
- "spec/spec_helper.rb"
- ]
+ s.rubyforge_project = "fssm"
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, [">= 0"])
- else
- s.add_dependency(%q<rspec>, [">= 0"])
- end
- else
- s.add_dependency(%q<rspec>, [">= 0"])
- end
+ s.add_development_dependency "rspec", "1.3.0"
end
-
View
1  lib/fssm.rb
@@ -23,6 +23,7 @@ def monitor(*args, &block)
require 'thread'
+require 'fssm/version'
require 'fssm/pathname'
require 'fssm/support'
require 'fssm/tree'
View
3  lib/fssm/version.rb
@@ -0,0 +1,3 @@
+module FSSM
+ VERSION = "0.2.4"
+end
Please sign in to comment.
Something went wrong with that request. Please try again.