New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot install gem digest 0.0.1 #426

Closed
alanholding opened this Issue Aug 19, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@alanholding

alanholding commented Aug 19, 2018

Running bundle install on a new installation of Slogger fails when trying to install the gem digest 0.0.1.

The output is:

bundle install
Fetching gem metadata from https://rubygems.org/...........
Resolving dependencies....
Using rake 12.3.1
Using public_suffix 3.0.3
Using addressable 2.5.2
Using buftok 0.2.0
Using bundler 1.16.3
Using safe_yaml 1.0.4
Using crack 0.4.3
Using thread_safe 0.3.6
Using descendants_tracker 0.0.4
Using diff-lcs 1.3
Fetching digest 0.0.1

Retrying download gem from https://rubygems.org/ due to error (2/4): Gem::RemoteFetcher::FetchError bad response Forbidden 403 (https://rubygems.org/gems/digest-0.0.1.gem)
Retrying download gem from https://rubygems.org/ due to error (3/4): Gem::RemoteFetcher::FetchError bad response Forbidden 403 (https://rubygems.org/gems/digest-0.0.1.gem)
Retrying download gem from https://rubygems.org/ due to error (4/4): Gem::RemoteFetcher::FetchError bad response Forbidden 403 (https://rubygems.org/gems/digest-0.0.1.gem)
Gem::RemoteFetcher::FetchError: bad response Forbidden 403
(https://rubygems.org/gems/digest-0.0.1.gem)
An error occurred while installing digest (0.0.1), and Bundler
cannot continue.
Make sure that `gem install digest -v '0.0.1' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  digest

I tried running the suggested command gem install digest -v '0.0.1' --source 'https://rubygems.org/' but that didn't work. I got this error message:

ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    bad response Forbidden 403 (https://api.rubygems.org/quick/Marshal.4.8/digest-0.0.1.gemspec.rz)

The reason for this seems to be given in this support form post on rubygems.org: http://help.rubygems.org/discussions/problems/31508-gem-install-digest-access-denied:

"…The gem digest is no longer accessible, as the name was in the reserved namespace we've locked off -- it was only in the search results by accident, and we no longer are able to provide access to it via rubygems.org. I apologize for any disruption this has caused you!"

I don't know how to proceed with the installation. Thanks.

@ttscoff

This comment has been minimized.

Show comment
Hide comment
@ttscoff

ttscoff Aug 21, 2018

Owner
Owner

ttscoff commented Aug 21, 2018

@alanholding

This comment has been minimized.

Show comment
Hide comment
@alanholding

alanholding Aug 27, 2018

OK. I'll remove the reference. Thanks. :)

alanholding commented Aug 27, 2018

OK. I'll remove the reference. Thanks. :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment