Permalink
Browse files

ruby1.8 compatibility isn't required to run gollum using ruby 1.8.7

The sanitize gem requires 1.8.7 or later, so compatibility with earlier versions is moot
  • Loading branch information...
1 parent d3594f6 commit df505a72899f4d0d9ed30131b030d465b2a748ae @tomafro tomafro committed Apr 12, 2011
Showing with 0 additions and 6 deletions.
  1. +0 −3 lib/gollum.rb
  2. +0 −3 lib/gollum/ruby1.8.rb
View
@@ -7,9 +7,6 @@
require 'github/markup'
require 'sanitize'
-# ruby 1.8 compatibility
-require 'gollum/ruby1.8'
-
# internal
require 'gollum/git_access'
require 'gollum/committer'
View
@@ -1,3 +0,0 @@
-class String
- alias :lines :to_a if defined?(RUBY_VERSION) && RUBY_VERSION < '1.9'
-end

0 comments on commit df505a7

Please sign in to comment.