Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Build error (appflower): download issue #106

Closed
alonswartz opened this issue Sep 13, 2013 · 4 comments

Comments

Projects
None yet
4 participants
@alonswartz
Copy link
Member

commented Sep 13, 2013

Dload  Upload   Total   Spent    Left  Speed
:--     0  0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 504
make: *** [build/stamps/root.patched] Error 22
@alonswartz

This comment has been minimized.

Copy link
Member Author

commented Sep 16, 2013

After installing from github including submodules (see turnkeylinux-apps/appflower@063e0f2), there are still issues:

+ /var/www/appflower/symfony project:permission
PHP Warning:  require_once(runtime/lib/Propel.php): failed to open stream: No such file or directory in /var/www/appflower/plugins/sfPropelORMPlugin/config/sfPropelORMPluginConfiguration.class.php on line 43
PHP Fatal error:  require_once(): Failed opening required 'runtime/lib/Propel.php' (include_path='/var/www/appflower:/var/www/appflower/plugins/sfPropelORMPlugin/lib/vendor/phing:/var/www/appflower/plugins/sfPropelORMPlugin/lib/vendor/propel:/var/www/appflower/plugins/sfPropelORMPlugin/lib/vendor/phing/../:/var/www/appflower/plugins/sfPropelORMPlugin/lib/vendor/phing/classes:/usr/share/pear') in /var/www/appflower/plugins/sfPropelORMPlugin/config/sfPropelORMPluginConfiguration.class.php on line 43

According to the readme:

In addition to these git repositories we a few other installations options available for those not choosing to use git. Visit the http://www.appflower.com/cms/download page for more details.

Which means, as long as the appflower websites are down (the original cause of the issue), this is a blocker...

@alonswartz alonswartz reopened this Sep 16, 2013

@nhereveri

This comment has been minimized.

Copy link

commented Feb 14, 2014

Maybe you install libs in ROOT lib/vendor dir?

Try to check where you install those, because README is a little confusing.

config/ProjectConfiguration.class.php

sfConfig::set('sf_phing_path', sfConfig::get('sf_root_dir').'/lib/vendor/phing/');
sfConfig::set('sf_propel_path', sfConfig::get('sf_root_dir').'/lib/vendor/propel/');
@JedMeister

This comment has been minimized.

Copy link
Member

commented Mar 19, 2015

It looks like appflower is now abandonware so closing this issue

@JedMeister JedMeister closed this Mar 19, 2015

@abidrcastaneda

This comment has been minimized.

Copy link

commented May 9, 2017

I think the sfcoreautoload.class.php is missing from the lib/vendor/symfony/ .... in fact, the folders only go all the way up to ../lib/vendor/symfony/ and that's it, there are missing files .....................

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.