Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Build error (drupal6): missing package #66

Closed
alonswartz opened this issue Aug 7, 2013 · 4 comments

Comments

Projects
None yet
2 participants
@alonswartz
Copy link
Member

commented Aug 7, 2013

Package drupal6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'drupal6' has no installation candidate

@Dude4Linux

This comment has been minimized.

Copy link
Member

commented Aug 20, 2013

Alon, It looks like you started to convert the drupal6 appliance so it was installed using pear and drush ala drupal7. There are still references to the debian drupal6 package in main. It should have worked by just copying main from the drupal7 appliance and changing the appropriate references from 7 to 6. I'm not sure why the drupal7 is failing on wheezy. I'll have a look as soon as I can get my tkldev setup working.

@alonswartz

This comment has been minimized.

Copy link
Member Author

commented Sep 8, 2013

@Dude4Linux I haven't updated the appliance to install drupal6 via drush, though that might be a good idea seeing as the package isn't available in Debian anymore.

None the less, I'm considering dropping the drupal6 appliance. Any new deployments should use Drupal7, and in the future Drupal8 once we create an appliance.

Any objections?

@Dude4Linux

This comment has been minimized.

Copy link
Member

commented Sep 10, 2013

@alonswartz, I agree that it doesn't make sense to continue the Drupal6 appliance since upstream support will stop when Drupal8 is released.  I still have a couple of Drupal6 sites that I've been too busy/lazy to upgrade.  I can't think of any reason why someone would want to start a new site using Drupal6.

@alonswartz

This comment has been minimized.

Copy link
Member Author

commented Sep 11, 2013

Agreed. TurnKey Drupal6 will be retired as of 13.0.
I'm closing this issue...

@alonswartz alonswartz closed this Sep 11, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.