New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

unable to install on NB7.2 #26

Closed
jdh13 opened this Issue Oct 18, 2012 · 7 comments

Comments

Projects
None yet
3 participants
@jdh13

jdh13 commented Oct 18, 2012

after downloading NBDrupalDevelTool.nbm and restarting IDE, i got the following errors:

Warning - could not install some modules:
Editor Hints - The module Editor Library 2 was requested in implementation version "31" but only "32" was found.
Editor Macros - The module Editor Library was requested in implementation version "19" but only "20" was found.
Editor Code Templates - The module named org.netbeans.spi.editor.hints/0-1 was needed and not found.
Common Scripting Language API (new) - The module named org.netbeans.spi.editor.hints/0-1 was needed and not found.
JavaScript Hints - The module named org.netbeans.spi.editor.hints/0-1 was needed and not found. Editor Formatting Prior 6.5 Separation - The module Editor Library 2 was requested in implementation version "31" but only "32" was found.
Editor Formatting Prior 6.5 Separation - The module Editor Library was requested in implementation version "19" but only "20" was found.
Tags Based Editors Library - The module named org.netbeans.modules.editor.deprecated.pre65formatting/0-1 was needed and not found.
XML Text Editor - The module named org.netbeans.modules.editor.deprecated.pre65formatting/0-1 was needed and not found.
IDE Platform - The module named org.netbeans.modules.editor.macros/0-1 was needed and not found. 40 further modules could not be installed due to the above problems.

@nakohdo

This comment has been minimized.

nakohdo commented Oct 19, 2012

The plug-in does work here with NB 7.2 on Win 2000 SP4 but I got a similar error message and was unable to install the plug-in on Windows 7 64 bit. So the problem might be related to the operating system.

@HollyIT

This comment has been minimized.

Collaborator

HollyIT commented Oct 22, 2012

Sounds like a messed up install of NetBeans. You might want to try uninstalling and clearing out all the cache directories (C:\users{username}\AppData\Local\NetBeans). That and make sure your Java is up to date.

Incidentally, this plugin was developed on Win7 64bit and I run it on there everyday.

@nakohdo

This comment has been minimized.

nakohdo commented Oct 22, 2012

Thanks for the hint. Will try and report back!

@nakohdo

This comment has been minimized.

nakohdo commented Oct 23, 2012

Still no luck.

I updated Java, re-installed NetBeans 7.2.1, deleted the cache and tried to install the plug-in (every available version) but it doesn't show up in the plugins list.

Product Version: NetBeans IDE 7.2.1 (Build 201210100934)
Java: 1.7.0_09; Java HotSpot(TM) 64-Bit Server VM 23.5-b02
System: Windows 7 version 6.1 running on amd64; Cp1252; de_DE (nb)

@HollyIT

This comment has been minimized.

Collaborator

HollyIT commented Oct 28, 2012

You need to download the NBM file and install it via the Download tab on the plugins window. Here's the current, stable one:

https://github.com/HollyIT/NBDrupalDevel/downloads

Save that, go to tools->plugins. From that window click the Download tab and then click Add Plugins. Select the NBM file and it should install from there. I just installed it on a clean Win7 64 machine with no problems at all.

@nakohdo

This comment has been minimized.

nakohdo commented Oct 29, 2012

Thanks for your patience! My bad, I downloaded the wrong file ...
Installs ok and works as promissed. Thanks for such a great tool!

@HollyIT

This comment has been minimized.

Collaborator

HollyIT commented Nov 1, 2012

Glad you got it working!

@HollyIT HollyIT closed this Nov 1, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment