Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Accessibility Request] Option To Toggle Swiping Between Tabs #1718

Open
CyberneticCody opened this issue Feb 28, 2020 · 9 comments
Open

[Accessibility Request] Option To Toggle Swiping Between Tabs #1718

CyberneticCody opened this issue Feb 28, 2020 · 9 comments

Comments

@CyberneticCody
Copy link

@CyberneticCody CyberneticCody commented Feb 28, 2020

I recently updated to the latest version of Tusky and have been fighting with the swipe to change tab feature. It would be great if we had an option in the settings to disable swiping between tabs. Often when scrolling because of how my thumb moves, I will swipe by accident instead of scrolling.

@charlag

This comment has been minimized.

Copy link
Collaborator

@charlag charlag commented Feb 29, 2020

Hi
It's a problem with Android library. Many deveelopers including us aren't happy about this so we expect them to change this

@RX14

This comment has been minimized.

Copy link

@RX14 RX14 commented Mar 3, 2020

@charlag can tusky offer an option to disable this as a short-term workaround? Tusky being difficult to use until this is fixed isn't fun :(

@CyberneticCody

This comment has been minimized.

Copy link
Author

@CyberneticCody CyberneticCody commented Mar 3, 2020

Agreed, especially considering a lot of people have Android phones that won't be getting updates to the OS and people that will get them far behind everyone else...

@charlag

This comment has been minimized.

Copy link
Collaborator

@charlag charlag commented Mar 3, 2020

We would really prefer to mot include such an option just as a workaround. It's not tied to Android version at all, it's support library

@RX14

This comment has been minimized.

Copy link

@RX14 RX14 commented Mar 4, 2020

I'm pretty sure it worked fine on the old tusky version. Aren't the support libraries bundled in the apk? Would it be feasible to downgrade that library?

Letting tusky accessibility be harmed because of a third party dependency isn't a good look... It's not like end users can change this or choose to avoid it.

@CyberneticCody

This comment has been minimized.

Copy link
Author

@CyberneticCody CyberneticCody commented Mar 4, 2020

Letting tusky accessibility be harmed because of a third party dependency isn't a good look... It's not like end users can change this or choose to avoid it.

I can agree with this, However, even with the library being up or downgraded this would still be a nice option to have.

@szyszyszyszy

This comment has been minimized.

Copy link

@szyszyszyszy szyszyszyszy commented Mar 9, 2020

I have experienced this issue as well. Frankly it's an accessibility issue.

@NeckbeardedDragon

This comment has been minimized.

Copy link

@NeckbeardedDragon NeckbeardedDragon commented Mar 9, 2020

I've never intentionally swiped between tabs, I always use the tab indicators at the top. An option to disable swiping between tabs would be very useful.

@CyberneticCody CyberneticCody changed the title [Feature request] Option To Toggle Swiping Between Tabs [Accessibility Request] Option To Toggle Swiping Between Tabs Mar 12, 2020
@konomikitten

This comment has been minimized.

Copy link

@konomikitten konomikitten commented Mar 14, 2020

This is driving me up the wall also and making Tusky unusable. I'd really like to see this fixed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
6 participants
You can’t perform that action at this time.