Skip to content
monorepo of power-assert runtime side
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
packages
test_helper
.gitignore
.travis.yml
CHANGELOG.md
LICENSE
README.md
lerna.json
package.json

README.md

power-assert

Build Status License

Reorganize empower, power-assert-formatter and power-assert-renderers into monorepo structure.

MODULES

DESIGN DECISION

  • Make ECMAScript parser optional at runtime
  • Make each module lightweight and small as possible
  • Avoid unnecessary dependencies
  • Make renderers less dynamic and statically analyzable. No dynamic require.

OUR SUPPORT POLICY

For the Transpiler side, we support Node under maintenance. In other words, we stop supporting old Node version when their maintenance ends.

For the Runtime side, we support Node under maintenance and "modern enough" browsers such as Chrome, Firefox, Safari, Edge etc.

Any other environments are not supported officially (means that we do not test against them on CI service). power-assert is known to work with old browsers, and trying to keep them working though.

AUTHOR

LICENSE

Licensed under the MIT license.

You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.