Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

table-bordered with tbody and no content = no border #13453

Closed
eintnohick opened this Issue Apr 28, 2014 · 7 comments

Comments

Projects
None yet
3 participants
@eintnohick
Copy link

eintnohick commented Apr 28, 2014

I noticed a weird behaviour when using table-bordered in Firefox...

http://jsfiddle.net/B3CWR/3/

This is a very specific issue only in FF so I'm not sure if yall want to address it but this does fix it:

thead+tbody:before{
    content:" ";
}

(The proposed fix actually makes the border-width bigger so I guess it's not a fix)

@cvrebert cvrebert added css labels Apr 28, 2014

@cvrebert

This comment has been minimized.

Copy link
Member

cvrebert commented Apr 28, 2014

Confirmed. Also confirmed that such HTML validates.
(Omitting the <tbody> altogether also makes the borders appear.)

@mdo

This comment has been minimized.

Copy link
Member

mdo commented May 1, 2014

Well that's super odd.

@cvrebert cvrebert added this to the v3.2.1 milestone Jun 9, 2014

@mdo

This comment has been minimized.

Copy link
Member

mdo commented Jun 11, 2014

This sounds like a browser bug @cvrebert, no?

@cvrebert

This comment has been minimized.

Copy link
Member

cvrebert commented Jun 11, 2014

@mdo Indeed. The bug occurs in Firefox on Mac OS X, Linux, and Windows 8.1.
I don't see the same behavior in any other browser.

@cvrebert cvrebert removed this from the v3.2.1 milestone Jun 11, 2014

@cvrebert

This comment has been minimized.

Copy link
Member

cvrebert commented Jun 11, 2014

Somewhat-reduced testcase: http://jsfiddle.net/dKTvW/5/

@cvrebert

This comment has been minimized.

Copy link
Member

cvrebert commented Jun 11, 2014

Filed upstream Firefox bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1023761
Now we just need to add this to our Wall of Browser Bugs.

@cvrebert

This comment has been minimized.

Copy link
Member

cvrebert commented Jul 26, 2015

Added a relevant test to the W3C CSS test suite: w3c/csswg-test#793

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.