Docs falsely claim "not-allowed" cursor for labels inside fieldset.disabled #16630

Closed
Herst opened this Issue Jun 12, 2015 · 6 comments

Projects

None yet

4 participants

@Herst
Herst commented Jun 12, 2015

From http://getbootstrap.com/css/#checkboxes-and-radios:

To have the for the checkbox or radio also display a "not-allowed" cursor when the user hovers over the label, add the .disabled class to your .radio, .radio-inline, .checkbox, .checkbox-inline, or <fieldset>

(bold highlighting by me)

Either the doc is wrong or the theme is missing something but adding the disabled class to an encompassing fieldset makes no difference.

Testcase with comparison to the other methods leading to the wanted result: http://jsbin.com/kacawu/3/edit?html,output (Bootlint and HTML validator passed).

@patrickhlauke patrickhlauke self-assigned this Jun 12, 2015
@patrickhlauke patrickhlauke added the docs label Jun 12, 2015
@cvrebert
Member

In the fieldset case, it should be the disabled attribute, as opposed to the disabled class; see https://github.com/twbs/bootstrap/blob/5a8d0143b3fa9de883a5672d4a1f44d472657a8a/less/forms.less#L262

@Herst
Herst commented Jun 12, 2015

@cvrebert Yes, but there are caveats as mentioned at http://getbootstrap.com/css/#forms-disabled-fieldsets

@cvrebert
Member

To further clarify, the disabled class has never been meant to be used on <fieldset>s.

@Herst
Herst commented Jun 12, 2015

OK, I just thought it might be useful for cross-browser compatibility.

In any case if you plan on mentioning the disabled attribute on fieldsets in the checkbox section of the docs maybe link then to the fieldset-disabled section as well so that people who might not read the whole manual are aware of possible issues when using that approach.

@patrickhlauke
Member

So unless I'm missing something, this is a simple case of the docs needing a tweak, right? Rather than the CSS? /cc @cvrebert

@cvrebert
Member

@patrickhlauke Correct.

@kkirsche kkirsche added a commit to kkirsche/bootstrap that referenced this issue Jun 12, 2015
@kkirsche kkirsche Clarify that <fieldset> only uses the disabled attribute
Fixes #16630
f0791d6
@patrickhlauke patrickhlauke removed their assignment Jun 15, 2015
@mdo mdo closed this in #16632 Jun 18, 2015
@mdo mdo added this to the v3.3.6 milestone Jun 18, 2015
@mdo mdo referenced this issue Jun 18, 2015
Closed

v3.3.6 ship list #16644

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment