New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

UNMET PEER DEPENDENCY jquery@>=3.0.0 and popper.js@^1.11.0 #24078

Closed
Boussarhane opened this Issue Sep 24, 2017 · 29 comments

Comments

Projects
None yet
@Boussarhane

Boussarhane commented Sep 24, 2017

I tried to install the latest version of Bootstrap 4 via : npm install bootstrap@4.0.0-beta

But I faced this problem :

+-- bootstrap@4.0.0-beta
+-- font-awesome@4.7.0
+-- UNMET PEER DEPENDENCY jquery@>=3.0.0
`-- UNMET PEER DEPENDENCY popper.js@^1.11.0

npm WARN bootstrap@4.0.0-beta requires a peer of jquery@>=3.0.0 but none was installed.
npm WARN bootstrap@4.0.0-beta requires a peer of popper.js@^1.11.0 but none was installed.
npm WARN b4starter@1.0.0 No repository field.

Why NPM doesn't install the dependencies?

@jrmvanderpoel

This comment has been minimized.

jrmvanderpoel commented Sep 25, 2017

I have the same problem and cant get it to work :/

installed jquery and popper.js. but still not working

@Johann-S

This comment has been minimized.

Member

Johann-S commented Sep 25, 2017

because you can use Bootstrap without that if you just need our CSS, but if you want to remove those warnings you can do npm i --save jquery popper.js

in our next release, you'll only have a warning about jQuery because currently we need Popper.js in our build system

@Johann-S Johann-S added the v4 label Sep 25, 2017

@sinedied

This comment has been minimized.

sinedied commented Sep 25, 2017

@Johann-S NPM currently reports this as an error, not a warning which is not great.
Could you consider moving them to optionalPeerDependencies, as it reflect more accurately the state of those dependencies (and does not trigger an NPM error)?
For example in my case I'm using ng-bootstrap, not I do not need those.

@Johann-S

This comment has been minimized.

Member

Johann-S commented Sep 25, 2017

That's not what I see when I look Boussarhane's message

npm WARN bootstrap@4.0.0-beta requires a peer of jquery@>=3.0.0 but none was installed.
npm WARN bootstrap@4.0.0-beta requires a peer of popper.js@^1.11.0 but none was installed.

I don't think we will use optionalPeerDependencies but we will ship different package for example bootstrap-css for those who just want our CSS

@sinedied

This comment has been minimized.

sinedied commented Sep 25, 2017

but we will ship different package for example bootstrap-css for those who just want our CSS

That would be perfect! 👍

@Johann-S Johann-S closed this Sep 25, 2017

@jrmvanderpoel

This comment has been minimized.

jrmvanderpoel commented Sep 25, 2017

I fixed the problem by removing bootstrap with
npm rm bootstrap@4.0.0-beta

and npm installed bootstrap again and problem was fixed

@reaganscofield

This comment has been minimized.

reaganscofield commented Oct 5, 2017

finally I'm alsom causing this problem on angular application i can only use version 3.3.7 when i tried to install version 4.0.0-beta i get that error and i can't used version 3 in the application please i need some help

@Johann-S

This comment has been minimized.

Member

Johann-S commented Oct 5, 2017

I already answered it, that's not an error but a warning and if you want to fix that you should install jQuery and Popper.js with : npm i jquery popper.js

@reaganscofield

This comment has been minimized.

reaganscofield commented Oct 5, 2017

i did still don't wanna work

@Johann-S

This comment has been minimized.

Member

Johann-S commented Oct 5, 2017

Sorry, but we cannot help with how-to or general troubleshooting issues here; only bug reports and feature requests. You'll want to ask around in the official Slack team or Stack Overflow. See our readme for more details.

@reaganscofield

This comment has been minimized.

reaganscofield commented Oct 5, 2017

ok can u help with the sources to find bootstrap 3.3.7 documentation for cards i look everywhere i in bootstrap 3 i can't find it

@jrmvanderpoel

This comment has been minimized.

jrmvanderpoel commented Oct 6, 2017

@reaganscofield @Johann-S

Installing jquery and popper doesnt work. At least for me. I had to removing bootstrap from npm and installing bootstrap bootstrap@4.0.0-alpha.6.

The jquery and popper warning only appears on bootstrap@4.0.0-beta. This is a problem that bootstrap has to fix themself.

installing alpha 6 did fix the problem for me

@Johann-S

This comment has been minimized.

Member

Johann-S commented Oct 6, 2017

That's not a problem but a choice we made, for some users they don't need jQuery and Popper.js they just need our CSS, so now it's on your end to add jQuery and Popper.js if you need them

@jrmvanderpoel

This comment has been minimized.

jrmvanderpoel commented Oct 6, 2017

True that. But I had css problems as well. Dont no where that occurred. And same jquery, like dropdowns didn't work as well :/

I now css has nothing to do with popper and jquery, but still there where css not properly loading

My colleague had the same problems.

@Johann-S

This comment has been minimized.

Member

Johann-S commented Oct 6, 2017

sorry but I cannot debug your application and not sure if it's related to that issue because when you have warnings on node that's doesn't break your application, it's just a information you have to take care

@jrmvanderpoel

This comment has been minimized.

jrmvanderpoel commented Oct 6, 2017

I know. Was just thinking there might be some little bug in beta4. But it doesnt matter to me anymore. Going back to alpha6 works for me ;)

@bvd

This comment has been minimized.

bvd commented Oct 10, 2017

@Johann-S

Thanks - your advice really helped me out and the problem disappeared. To me this looks just like a normal dependency issue and not a bug of sorts.

@ruwhan

This comment has been minimized.

ruwhan commented Oct 24, 2017

hello guys, I also get the errors

npm ERR! peer dep missing: popper.js@^1.12.3, required by bootstrap@4.0.0-beta.2

I'm using react-starter-kit, anyone have ever solved it or encounter the same issue?

Thanks in advance.

@emirotin

This comment has been minimized.

emirotin commented Nov 13, 2017

I'm only using CSS from the package and I'm still getting the jquery peer dep warning

WARN bootstrap@4.0.0-beta.2 requires a peer of jquery@1.9.1 - 3 but none was installed

@wolfy1339

This comment has been minimized.

Contributor

wolfy1339 commented Nov 13, 2017

It doesn't matter if you only use the CSS, if you install bootstrap from npm, you get that warning

@emirotin

This comment has been minimized.

emirotin commented Nov 13, 2017

@wolfy1339 yes, I know how npm deps work. What I'm saying is there's a legit use case where people don't care about jQuery, so I'm raising my voice for removing this peer dep or releasing a separate css-only package as suggested above.

@jrmvanderpoel

This comment has been minimized.

jrmvanderpoel commented Nov 14, 2017

For me it doesnt matter if i want to use only css or not. Both css and jquery are not working with bootstrap beta 4 and beta 2. Especially .card class. And al the javascript do not work

@Johann-S

This comment has been minimized.

Member

Johann-S commented Nov 14, 2017

Everything work @jrmvanderpoel it seems an issue on your end 😉

@jrmvanderpoel

This comment has been minimized.

jrmvanderpoel commented Nov 14, 2017

@Johann-S I know. Only if i could figure out what it is :) I really want to update to the newest bootstrap version

programmiri added a commit to programmiri/brunch-setup-bootstrap4 that referenced this issue Mar 18, 2018

Update to bootstrap version 4.0.0
* remove tether.js
* updating dependencies for jquery and popper.js (see twbs/bootstrap#24078)
* update scss imports
@derchirurg

This comment has been minimized.

derchirurg commented May 8, 2018

I get the same warning when installing bootstrap per npm.
But I get an Error if I use npm shrinkwrap.
npm ERR! peer invalid: jquery@1.9.1 - 3, required by bootstrap@4.1.1
npm ERR! peer invalid: popper.js@^1.14.3, required by bootstrap@4.1.1

What can I do?

@quirimmo

This comment has been minimized.

quirimmo commented May 14, 2018

Being used just for dev, it could be installed directly as dev dependency in order to remove the warning, rather than bring it back in the dependencies:

npm i --save-dev popper.js

@xfg

This comment has been minimized.

xfg commented Jun 11, 2018

@Johann-S when the bootstrap-css will be released?

@NodiraIbrogimova

This comment has been minimized.

NodiraIbrogimova commented Jun 29, 2018

I tried many options, including options above none of them worked. I closed and reopened the IDE ( VS Code in my case :) ) and it suddenly worked. Hallelujah!

@rernesto

This comment has been minimized.

rernesto commented Nov 16, 2018

"bootstrap@4.1.3" has unmet peer dependency "popper.js@^1.14.3" it is not only a warning from npm for me, because I am using Yarn and Webpack and Webpack it is not compiling because can't find popper dependency. If I try to install "popper.js@^1.14.3" at least yarn is telling me that version doesn't exists.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment