Permalink
Browse files

Updates snyk

  • Loading branch information...
twhite96 committed Oct 15, 2017
1 parent e674743 commit b6c05971c5c4aeb7998df50e5594a23c1e33efed
Showing with 113 additions and 8 deletions.
  1. +110 −5 .snyk
  2. +3 −3 package.json
View
115 .snyk
@@ -1,14 +1,119 @@
# Snyk (https://snyk.io) policy file, patches or ignores known vulnerabilities.
version: v1.7.1
ignore: {}
# ignores vulnerabilities until expiry date; change duration by modifying expiry date
ignore:
'npm:debug:20170905':
- snyk > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-module > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-try-require > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-policy > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-policy > snyk-module > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-policy > snyk-resolve > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-policy > snyk-try-require > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-config > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > snyk-module > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > snyk-resolve > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > snyk-try-require > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > clite > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > needle > debug:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- v8-profiler > node-pre-gyp > tar-pack > debug:
reason: No update available. Revisting this dependency
expires: '2017-11-14T03:31:20.984Z'
'npm:ms:20170412':
- snyk > snyk-resolve-deps > clite > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > needle > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-module > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-try-require > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-policy > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-policy > snyk-module > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-policy > snyk-resolve > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-policy > snyk-try-require > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-config > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > snyk-module > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > snyk-resolve > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- snyk > snyk-resolve-deps > snyk-try-require > debug > ms:
reason: no updates available
expires: '2017-11-14T03:31:20.984Z'
- v8-profiler > node-pre-gyp > tar-pack > debug > ms:
reason: No update available. Revisting this dependency
expires: '2017-11-14T03:31:20.984Z'
# patches apply the minimum changes required to fix a vulnerability
patch:
'npm:minimatch:20160620':
- gulp > vinyl-fs > glob-stream > minimatch:
patched: '2017-10-09T00:06:10.121Z'
patched: '2017-10-15T03:31:57.785Z'
- gulp > vinyl-fs > glob-stream > glob > minimatch:
patched: '2017-10-09T00:06:10.121Z'
patched: '2017-10-15T03:31:57.785Z'
- gulp > vinyl-fs > glob-watcher > gaze > globule > glob > minimatch:
patched: '2017-10-09T00:06:10.121Z'
patched: '2017-10-15T03:31:57.785Z'
- gulp > vinyl-fs > glob-watcher > gaze > globule > minimatch:
patched: '2017-10-09T00:06:10.121Z'
patched: '2017-10-15T03:31:57.785Z'
'npm:debug:20170905':
- gulp-qunit > phantomjs-prebuilt > extract-zip > debug:
patched: '2017-10-15T03:31:57.785Z'
'npm:ms:20170412':
- gulp-qunit > phantomjs-prebuilt > extract-zip > debug > ms:
patched: '2017-10-15T03:31:57.785Z'
View
@@ -28,10 +28,10 @@
"multi-views": "^0.1.1",
"natural": "^0.5.4",
"serve-favicon": "^2.4.5",
"snyk": "^1.42.4",
"spell-checker": "0.0.26",
"v8-profiler": "^5.7.0",
"write-good": "^0.11.3",
"snyk": "^1.42.4"
"write-good": "^0.11.3"
},
"engines": {
"node": "8.2.1"
@@ -48,4 +48,4 @@
},
"homepage": "https://github.com/twhite96/checkyoself#readme",
"snyk": true
}
}

0 comments on commit b6c0597

Please sign in to comment.