Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 35 lines (30 sloc) 1.73 kB
908713f @karlfreeman refresh .gemspec
karlfreeman authored
1 # coding: utf-8
2 lib = File.expand_path('../lib', __FILE__)
3 $LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
4 require 'twilio-ruby/version'
608b391 @andrewmbenton setting up Twilio::VERSION and adding documentation
andrewmbenton authored
5
908713f @karlfreeman refresh .gemspec
karlfreeman authored
6 Gem::Specification.new do |spec|
7 spec.name = 'twilio-ruby'
8 spec.version = Twilio::VERSION
9 spec.authors = ['Andrew Benton']
10 spec.email = ['andrew@twilio.com']
11 spec.summary = 'A simple library for communicating with the Twilio REST API, building TwiML, and generating Twilio Client Capability Tokens'
12 spec.description = 'A simple library for communicating with the Twilio REST API, building TwiML, and generating Twilio Client Capability Tokens'
13 spec.homepage = 'http://github.com/twilio/twilio-ruby'
14 spec.license = 'MIT'
d31344f @andrewmbenton updating gemspec for rdoc and development version bump
andrewmbenton authored
15
908713f @karlfreeman refresh .gemspec
karlfreeman authored
16 spec.files = `git ls-files -z`.split("\x0")
17 spec.executables = spec.files.grep(%r{^bin/}) { |f| File.basename(f) }
18 spec.test_files = spec.files.grep(%r{^(test|spec|features)/})
19 spec.require_paths = ['lib']
116870c @philnash Bumps required ruby version.
philnash authored
20 spec.required_ruby_version = '>= 1.9.3'
908713f @karlfreeman refresh .gemspec
karlfreeman authored
21 spec.extra_rdoc_files = ['README.md', 'LICENSE.md']
22 spec.rdoc_options = ['--line-numbers', '--inline-source', '--title', 'twilio-ruby', '--main', 'README.md']
d31344f @andrewmbenton updating gemspec for rdoc and development version bump
andrewmbenton authored
23
908713f @karlfreeman refresh .gemspec
karlfreeman authored
24 spec.add_dependency('multi_json', '>= 1.3.0')
25 spec.add_dependency('builder', '>= 2.1.2')
1e8c4a3 update jwt version
Kush Kella authored
26 spec.add_dependency('jwt', '~> 1.0')
908713f @karlfreeman refresh .gemspec
karlfreeman authored
27 spec.add_dependency('jruby-openssl') if RUBY_PLATFORM == 'java'
6d9db95 Add rubysl workaround for Rubinius
Carlos Diaz-Padron authored
28 # Workaround for RBX <= 2.2.1, should be fixed in next version
908713f @karlfreeman refresh .gemspec
karlfreeman authored
29 spec.add_dependency('rubysl') if defined?(RUBY_ENGINE) && RUBY_ENGINE == 'rbx'
96e7810 @andrewmbenton merging develop with local changes
andrewmbenton authored
30
908713f @karlfreeman refresh .gemspec
karlfreeman authored
31 spec.add_development_dependency 'bundler', '~> 1.5'
0968e91 @dougblack typo
dougblack authored
32 spec.extra_rdoc_files = ['README.md', 'LICENSE.md']
33 spec.rdoc_options = ['--line-numbers', '--inline-source', '--title', 'twilio-ruby', '--main', 'README.md']
c8a763e @andrewmbenton new twilio-ruby finally :)
andrewmbenton authored
34 end
Something went wrong with that request. Please try again.