Permalink
Fetching contributors…
Cannot retrieve contributors at this time
198 lines (144 sloc) 5.21 KB

twilio-ruby

Build Status Gem Version Code Quality

A module for using the Twilio REST API and generating valid TwiML. Click here to read the full documentation.

Recent Update

As of release 5.1.0, Beta and Developer Preview products are now exposed via the main twilio-ruby artifact. Releases of the alpha branch have been discontinued.

If you were using the alpha release line, you should be able to switch back to the normal release line without issue.

If you were using the normal release line, you should now see several new product lines that were historically hidden from you due to their Beta or Developer Preview status. Such products are explicitly documented as Beta/Developer Preview both in the Twilio docs and console, as well as through in-line code documentation here in the library.

Installation

To install using Bundler grab the latest stable version:

gem 'twilio-ruby', '~> 5.15.1'

To manually install twilio-ruby via Rubygems simply gem install:

gem install twilio-ruby -v 5.15.1

To build and install the development branch yourself from the latest source:

git clone git@github.com:twilio/twilio-ruby.git
cd twilio-ruby
make install

Migration from 4.x

Upgrade Guide

Documentation

Here

Docker Image

The Dockerfile present in this repository and its respective twilio/twilio-ruby Docker image are currently used by Twilio for testing purposes only.

Feedback

During the Release Candidate period of this library, please leave all feedback and issues in the Github Issues for twilio-ruby.

Getting Started

Setup Work

require 'twilio-ruby'

# put your own credentials here
account_sid = 'ACxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
auth_token = 'yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy'

# set up a client to talk to the Twilio REST API
@client = Twilio::REST::Client.new account_sid, auth_token

Make a Call

@client.api.account.calls.create(
  from: '+14159341234',
  to: '+16105557069',
  url: 'http://example.com'
)

Send an SMS

@client.api.account.messages.create(
  from: '+14159341234',
  to: '+16105557069',
  body: 'Hey there!'
)

List your SMS Messages

@client.api.account.messages.list

Fetch a single SMS message by Sid

# put the message sid you want to retrieve here:
message_sid = 'SMxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
@client.api.account.messages(message_sid).fetch

Customizing your HTTP Client

twilio-ruby uses Faraday to make HTTP requests. You can tell Twilio::REST::Client to use any of the Faraday adapters like so:

@client.http_client.adapter = :typhoeus

Getting Started With Client Capability Tokens

If you just need to generate a Capability Token for use with Twilio Client, you can do this:

require 'twilio-ruby'

# put your own account credentials here:
account_sid = 'ACxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
auth_token = 'yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy'

# set up
capability = Twilio::JWT::ClientCapability.new account_sid, auth_token

# allow outgoing calls to an application
outgoing_scope = Twilio::JWT::ClientCapability::OutgoingClientScope.new 'AP11111111111111111111111111111111'
capability.add_scope(outgoing_scope)

# allow incoming calls to 'andrew'
incoming_scope = Twilio::JWT::ClientCapability::IncomingClientScope.new 'andrew'
capability.add_scope(incoming_scope)

# generate the token string
@token = capability.to_s

There is a slightly more detailed document in the Capability section of the wiki.

Getting Started With TwiML

You can construct a TwiML response like this:

require 'twilio-ruby'

response = Twilio::TwiML::VoiceResponse.new do |r|
  r.say(message: 'hello there', voice: 'alice')
  r.dial(caller_id: '+14159992222') do |d|
    d.client 'jenny'
  end
end

# print the result
puts response.to_s

This will print the following (except for the whitespace):

<?xml version="1.0" encoding="UTF-8"?>
<Response>
  <Say voice="alice">hello there</Say>
  <Dial callerId="+14159992222">
    <Client>jenny</Client>
  </Dial>
</Response>

Supported Ruby Versions

This library supports and is tested against the following Ruby implementations:

  • Ruby 2.5.0
  • Ruby 2.4.0
  • Ruby 2.3.0
  • Ruby 2.2.0