Latest commit e8de9d1 May 11, 2016 @mateor mateor committed with kwlzn Update the futures library.
This bumps futures to a more modern version,
some useful Python libraries are pinned to a range
that is later than the current t.c. `futures` version.

ex. boto3 is pinned to `futures>=2.2.0,<4.0.0` for python2.7

This is the minimum-viable change that makes the t.c.
libs compatible.

Testing Done:
Ran ci.sh locally and Travis passed: #428

Bugs closed: 427, 428

Reviewed at https://rbcommons.com/s/twitter/r/3857/
Permalink
..
Failed to load latest commit information.
jvm [twitter/commons] Upgrade pants from 0.0.44 -> 0.0.59 Nov 21, 2015
python Update the futures library. May 10, 2016