Upgrade libthrift? #206

eirslett opened this Issue Oct 15, 2013 · 18 comments


None yet

Will the dependency on libthrift ever be upgraded from 0.5.* to 0.9.*, the latest version?


bmdhacks commented Oct 15, 2013

It's on our list of things to do, but we haven't committed it to the schedule.


mariusae commented Oct 16, 2013

More generally, we hope to remove the thrift dependency altogether.

Are there any recent plans on upgrading the libthrift dependency?



stevegury commented Dec 1, 2014

That's still something that we want to do, but that's not our main priority right now.


itszero commented Feb 9, 2015

Looks like libthrift-0.5.0 disappeared on maven.org. Could we bump up the priority a little bit?


nshkrob commented Feb 10, 2015

Upgrading to a recent libthrift version would involve some work for us internally, so it's not a priority at the moment.

In the meantime, you can use the http://maven.twttr.com to get libthrift-0.5.0:

MayiTiny commented Jul 1, 2015

I found that it have a conflict between libthrift0.8.0(in storm) and libthrift0.5.0(in finagle). But I must use both storm and finagle for some reason.I see there is still no schedule to upgrade or remove thrift dependency.
So I upgrade thrift dependency to 0.8 and change the thrift file which generated by scrooge manually.
It works well at present.
I hope it can work continuous...


taylorleese commented Jul 1, 2015

Upgrading libthrift is on the long-term radar. There are some logistics that need to be sorted out first.

drozzy commented Oct 28, 2015

With all due respect, how is this not a priority? The dependency has disappeared off the maven altogether (try that - gives you an error):

I am trying to install scrooge-core 4.2.0 and finagle-thrift_2.11" % 6.30.0 but this is really making the whole thing impossible.


mosesn commented Oct 28, 2015

Hi @drozzy, sorry you've had trouble with this. As @nshkrob mentioned, you can use maven.twttr.com in the mean time. Note that it uses ssl now, so you'll want to go to https://maven.twttr.com/org/apache/thrift/libthrift/0.5.0/

You can easily use libthrift 0.9.2 with finagle, no problem. As long as you use the Java generator. (Unless you hit an edge-case.) Just override the version you get from finagle.

drozzy commented Oct 28, 2015

@mosesn Thanks, I think I'll use the jar after all. Seems like a hack though :-)

@eirslett Forgive me, but I don't think I know what you mean... I'm going to use the scrooge sbt plugin.

You can use sbt and exclude the version of libthrift that finagle gives you. And then you must include your own version instead. (0.9.2?)
Use the latest version of the scrooge sbt plugin. Then it should just work - I think... (at least it worked for me)

drozzy commented Oct 28, 2015

@eirslett But scrooge-sbt-plugin requires Scala 2.10, while scrooge-core is available for Scala 2.11... :( This is like solving a detective mystery :-)

P.S.: Do you know how I can find version "3.18.1" of scrooge-sbt-plugin in the https://oss.sonatype.org/content/groups/public/
I'm thinking of modifying the scala dependency....

P.S.S: I think I'll post this on scrooge issues board... twitter/scrooge#212

Too bad the sbt plugin isn't published... but it's only one file, you could simply copy-paste it directly into your project:


drozzy commented Oct 28, 2015

@eirslett So here is a stupid question... where would I copy it? Into project/ScroogeSBT.scala?

exactly. And add the scrooge-generator dependencies etc. to project/plugins.sbt.


mosesn commented May 29, 2016

This is a duplicate of #133, so I'm going to close this ticket. Unfortunately, it's still a low priority internally to fix this.

mosesn closed this May 29, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment