Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

LoadError when requiring twitter-text as a dependency #60

Open
sferik opened this Issue May 3, 2012 · 0 comments

Comments

Projects
None yet
1 participant
Contributor

sferik commented May 3, 2012

The t gem depends on twitter-text to extract mentioned screen names from Tweet text.

Five separate users, all on different operating systems and Ruby versions, reported a LoadError on the line where I require 'twitter-text'.

Originally, I assumed it was an environmental issue, since I was unable to reproduce the problem on my machine, however, when I released a version of the gem (0.9.4), which lazy-loaded twitter-text, users reported the problem had been fixed.

As you can see from this GitHub compare view, the only difference between version 0.9.3, where users were reporting a problem, and 0.9.4, where users reported that it was fixed is the lazy-loading of twitter-text: sferik/t@v0.9.3...v0.9.4

Again, I am unable to reproduce the error, but I believe that there is a problem with requiring twitter-text as a dependency on some systems, which I thought you'd want to know about.

I am considering reimplementing the extract_mentioned_screen_names functionality that I'm using from twitter-text within the t gem, however I'd prefer to depend on twitter-text than maintain that code myself.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment