Skip to content
Browse files

Replace Gem::PackageTask with Bundler::GemHelper.install_tasks

  • Loading branch information...
1 parent 789f1d1 commit ed382d78829320afdbadec6af3ef90511bc93019 @sferik sferik committed
Showing with 2 additions and 22 deletions.
  1. +2 −22 Rakefile
View
24 Rakefile
@@ -1,6 +1,7 @@
#!/usr/bin/env rake
require 'rake/testtask'
require 'rubygems/package_task'
+require 'bundler'
task :default => :test
@@ -9,25 +10,4 @@ Rake::TestTask.new do |test|
test.verbose = true
end
-namespace :dist do
- spec = Gem::Specification.load('twurl.gemspec')
-
- Gem::PackageTask.new(spec) do |pkg|
- pkg.need_tar_gz = true
- pkg.package_files.include('{lib,bin,test}/**/*')
- pkg.package_files.include('README')
- pkg.package_files.include('COPYING')
- pkg.package_files.include('INSTALL')
- pkg.package_files.include('Rakefile')
- end
-
- task :spec do
- puts spec.to_ruby
- end
-
- desc "Unpack current version of library into the twitter.com vendor directory"
- task :unpack_to_vendor => :repackage do
- cd 'pkg'
- system("gem unpack '#{spec.name}-#{spec.version}.gem' --target=$TWITTER/vendor/gems")
- end
-end
+Bundler::GemHelper.install_tasks

0 comments on commit ed382d7

Please sign in to comment.
Something went wrong with that request. Please try again.