Permalink
Browse files

Adding gemspec. Hopfully gem will build on GitHub now

  • Loading branch information...
1 parent 5fd88ba commit 6a096dd43479e8b1ae93aaee7899ecdca1c97c1e @brynary brynary committed Nov 25, 2008
Showing with 36 additions and 3 deletions.
  1. +4 −2 Rakefile
  2. +1 −1 install.rb
  3. +31 −0 webrat.gemspec
View
6 Rakefile
@@ -21,14 +21,16 @@ spec = Gem::Specification.new do |s|
s.bindir = "bin"
s.description = s.summary
s.require_path = "lib"
- s.files = %w(History.txt init.rb install.rb MIT-LICENSE.txt README.txt Rakefile) + Dir["lib/**/*"]
+ s.files = %w(History.txt init.rb install.rb MIT-LICENSE.txt README.rdoc Rakefile) + Dir["lib/**/*"]
# rdoc
s.has_rdoc = true
- s.extra_rdoc_files = %w(README.txt MIT-LICENSE.txt)
+ s.extra_rdoc_files = %w(README.rdoc MIT-LICENSE.txt)
# Dependencies
s.add_dependency "nokogiri", ">= 1.0.3"
+
+ s.rubyforge_project = "webrat"
end
Rake::GemPackageTask.new(spec) do |package|
View
2 install.rb
@@ -1 +1 @@
-puts IO.read(File.join(File.dirname(__FILE__), 'README.txt'))
+puts IO.read(File.join(File.dirname(__FILE__), 'README.rdoc'))
View
31 webrat.gemspec
@@ -0,0 +1,31 @@
+Gem::Specification.new do |s|
+ s.name = %q{webrat}
+ s.version = "0.3.2.1"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Bryan Helmkamp"]
+ s.date = %q{2008-11-24}
+ s.description = %q{Webrat. Ruby Acceptance Testing for Web applications}
+ s.email = %q{bryan@brynary.com}
+ s.extra_rdoc_files = ["README.rdoc", "MIT-LICENSE.txt"]
+ s.files = ["History.txt", "init.rb", "install.rb", "MIT-LICENSE.txt", "README.rdoc", "Rakefile", "lib/webrat", "lib/webrat/core", "lib/webrat/core/area.rb", "lib/webrat/core/configuration.rb", "lib/webrat/core/field.rb", "lib/webrat/core/form.rb", "lib/webrat/core/hpricot.rb", "lib/webrat/core/label.rb", "lib/webrat/core/link.rb", "lib/webrat/core/locators.rb", "lib/webrat/core/logging.rb", "lib/webrat/core/matchers", "lib/webrat/core/matchers/have_content.rb", "lib/webrat/core/matchers/have_selector.rb", "lib/webrat/core/matchers/have_tag.rb", "lib/webrat/core/matchers/have_xpath.rb", "lib/webrat/core/matchers.rb", "lib/webrat/core/methods.rb", "lib/webrat/core/mime.rb", "lib/webrat/core/nokogiri.rb", "lib/webrat/core/rexml.rb", "lib/webrat/core/scope.rb", "lib/webrat/core/select_option.rb", "lib/webrat/core/session.rb", "lib/webrat/core/xml.rb", "lib/webrat/core.rb", "lib/webrat/core_extensions", "lib/webrat/core_extensions/blank.rb", "lib/webrat/core_extensions/deprecate.rb", "lib/webrat/core_extensions/detect_mapped.rb", "lib/webrat/core_extensions/hash_with_indifferent_access.rb", "lib/webrat/core_extensions/meta_class.rb", "lib/webrat/core_extensions/nil_to_param.rb", "lib/webrat/mechanize.rb", "lib/webrat/merb.rb", "lib/webrat/rack.rb", "lib/webrat/rails", "lib/webrat/rails/redirect_actions.rb", "lib/webrat/rails.rb", "lib/webrat/rspec-rails.rb", "lib/webrat/selenium", "lib/webrat/selenium/location_strategy_javascript", "lib/webrat/selenium/location_strategy_javascript/button.js", "lib/webrat/selenium/location_strategy_javascript/label.js", "lib/webrat/selenium/location_strategy_javascript/webrat.js", "lib/webrat/selenium/location_strategy_javascript/webratlink.js", "lib/webrat/selenium/location_strategy_javascript/webratlinkwithin.js", "lib/webrat/selenium/location_strategy_javascript/webratselectwithoption.js", "lib/webrat/selenium/selenium_extensions.js", "lib/webrat/selenium/selenium_session.rb", "lib/webrat/selenium.rb", "lib/webrat/sinatra.rb", "lib/webrat.rb"]
+ s.has_rdoc = true
+ s.homepage = %q{http://github.com/brynary/webrat}
+ s.require_paths = ["lib"]
+ s.rubyforge_project = %q{webrat}
+ s.rubygems_version = %q{1.3.1}
+ s.summary = %q{Webrat. Ruby Acceptance Testing for Web applications}
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 2
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<nokogiri>, [">= 1.0.3"])
+ else
+ s.add_dependency(%q<nokogiri>, [">= 1.0.3"])
+ end
+ else
+ s.add_dependency(%q<nokogiri>, [">= 1.0.3"])
+ end
+end

0 comments on commit 6a096dd

Please sign in to comment.