Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 77 lines (71 sloc) 2.484 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = %q{grip}
  s.version = "0.6.9"

  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.authors = ["twoism", "jnunemaker"]
  s.date = %q{2010-01-21}
  s.description = %q{GridFS attachments for MongoMapper}
  s.email = %q{signalstatic@gmail.com}
  s.extra_rdoc_files = [
    "LICENSE",
     "README.markdown"
  ]
  s.files = [
    ".gitignore",
     "LICENSE",
     "README.markdown",
     "Rakefile",
     "VERSION",
     "grip.gemspec",
     "lib/grip.rb",
     "lib/grip/attachment.rb",
     "lib/grip/has_attachment.rb",
     "test/factories.rb",
     "test/fixtures/cthulhu.png",
     "test/fixtures/fennec-fox.jpg",
     "test/fixtures/sample.pdf",
     "test/grip_attachment_test.rb",
     "test/has_attachment_test.rb",
     "test/models.rb",
     "test/test_helper.rb"
  ]
  s.homepage = %q{http://github.com/twoism/grip}
  s.rdoc_options = ["--charset=UTF-8"]
  s.require_paths = ["lib"]
  s.rubygems_version = %q{1.3.5}
  s.summary = %q{GridFS attachments for MongoMapper}
  s.test_files = [
    "test/factories.rb",
     "test/grip_attachment_test.rb",
     "test/has_attachment_test.rb",
     "test/models.rb",
     "test/test_helper.rb"
  ]

  if s.respond_to? :specification_version then
    current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
    s.specification_version = 3

    if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
      s.add_runtime_dependency(%q<mongo_mapper>, [">= 0.6.10"])
      s.add_runtime_dependency(%q<rmagick>, [">= 2.12.2"])
      s.add_runtime_dependency(%q<miso>, [">= 0.3.1"])
      s.add_development_dependency(%q<factory_girl>, ["= 1.2.3"])
      s.add_development_dependency(%q<shoulda>, ["= 2.10.2"])
    else
      s.add_dependency(%q<mongo_mapper>, [">= 0.6.10"])
      s.add_dependency(%q<rmagick>, [">= 2.12.2"])
      s.add_dependency(%q<miso>, [">= 0.3.1"])
      s.add_dependency(%q<factory_girl>, ["= 1.2.3"])
      s.add_dependency(%q<shoulda>, ["= 2.10.2"])
    end
  else
    s.add_dependency(%q<mongo_mapper>, [">= 0.6.10"])
    s.add_dependency(%q<rmagick>, [">= 2.12.2"])
    s.add_dependency(%q<miso>, [">= 0.3.1"])
    s.add_dependency(%q<factory_girl>, ["= 1.2.3"])
    s.add_dependency(%q<shoulda>, ["= 2.10.2"])
  end
end

Something went wrong with that request. Please try again.