Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Add inital setup script

  • Loading branch information...
commit 7da3567dce34f941220ff16da6e1938fe9722194 1 parent a0ea0f5
@twpayne authored
Showing with 58 additions and 0 deletions.
  1. +5 −0 .gitignore
  2. +1 −0  MANIFEST.in
  3. +7 −0 setup.cfg
  4. +45 −0 setup.py
View
5 .gitignore
@@ -1,7 +1,12 @@
+/EGG-INFO
/bin
/distribute-*.tar.gz
/include
/lib
+/man
+/tilecloud.egg-info
+.coverage
+*.egg
*.jpg
*.log
*.mbtiles
View
1  MANIFEST.in
@@ -0,0 +1 @@
+include README.md
View
7 setup.cfg
@@ -0,0 +1,7 @@
+[nosetests]
+match=^test
+where=tilecloud
+nocapture=1
+cover-package=tilecloud
+with-coverage=1
+cover-erase=1
View
45 setup.py
@@ -0,0 +1,45 @@
+from setuptools import setup, find_packages
+import os
+
+version = '0.1'
+
+here = os.path.abspath(os.path.dirname(__file__))
+README = open(os.path.join(here, 'README.md')).read()
+
+install_requires = [
+ 'bottle',
+ 'pyproj',
+ ]
+
+setup_requires = [
+ 'nose',
+ ]
+
+tests_require = install_requires = [
@fredj Collaborator
fredj added a note

tests_require = install_requires + ['coverage'] instead ?

@twpayne Owner
twpayne added a note

Indeed, thanks @fredj! Fixed in 2b05c75.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+ 'coverage',
+ ]
+
+setup(
+ name='tilecloud',
+ version=version,
+ description='Tools for managing tiles',
+ classifiers=[
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Programming Language :: Python',
+ ],
+ author='Tom Payne',
+ author_email='twpayne@gmail.com',
+ url='http://github.com/twpayne/tilecloud',
+ license='BSD',
+ packages=find_packages(exclude=['tiles']),
+ zip_safe=True,
+ install_requires=install_requires,
+ setup_requires=setup_requires,
+ tests_require=tests_require,
+ test_suite='tilecloud.tests',
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+ long_description=README,
+ )
@fredj
Collaborator

tests_require = install_requires + ['coverage'] instead ?

@twpayne
Owner

Indeed, thanks @fredj! Fixed in 2b05c75.

Please sign in to comment.
Something went wrong with that request. Please try again.