Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Support latest AWS SDK #9

Merged
merged 1 commit into from

2 participants

@mileszs

The latest AWS SDK requires an associative array including 'key' and 'secret', if passing those directly. This change is working for me currently.

Are you still using this, by chance? Are there any other related, client-side performance tools you recommend, beyond the obvious of YSlow, of course. Thanks!

@tylerhall tylerhall merged commit 61faebe into from
@tylerhall
Owner

Thanks for the fix!

@tylerhall
Owner

YSlow plus the work Steve Souders is going with Google Pagespeed should be all you need to keep your site speedy.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 6, 2012
  1. Latest AWS SDK requires array in constructor

    Miles Z. Sterrett authored
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 2 deletions.
  1. +2 −2 autosmush
View
4 autosmush
@@ -64,7 +64,7 @@
$total_uncompressed_bytes = 0;
// Get the bucket's contents...
- $s3 = new AmazonS3(AWS_S3_KEY, AWS_S3_SECRET);
+ $s3 = new AmazonS3(array('key' => AWS_S3_KEY, 'secret' => AWS_S3_SECRET));
$options = array('prefix' => $bucket_path);
// Check bucket's headers
@@ -187,4 +187,4 @@
array_shift($unit);
}
return round($val, $round) . array_shift($unit) . 'B';
- }
+ }
Something went wrong with that request. Please try again.