New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade to T5.4 #1

Closed
kaosko opened this Issue Oct 8, 2014 · 0 comments

Comments

Projects
None yet
1 participant
@kaosko
Member

kaosko commented Oct 8, 2014

No description provided.

@kaosko kaosko self-assigned this Oct 8, 2014

kaosko added a commit that referenced this issue Oct 9, 2014

OPEN - #1: Upgrade to T5.4
- the initial work for the upgrade is done but not properly tested
- esxx-httpclient-gae is now completely completely out. It's unclear
whether it's needed anymore (I don't see GAE users complaining about it
and at least at
http://krasserm.blogspot.com/2010/01/accessing-security-enabled-google-app.html,
the blogger seems to be using httpclient on GAE just fine). It has a
dependency to an old version of httpclient so either we'd need to
upgrade the library or remove it
- before any T5.4 compatible release, we need to at least rewrite the
JavaScript parts of the CollapsiblePanel component as a requirejs
module. The OauthSignIn.js can stay as a library because it's a
self-contained page

kaosko added a commit that referenced this issue Nov 5, 2014

OPEN - #1: Upgrade to T5.4
- remove references to classes in org.esxx.js package
- deprecate symbole HTTPCLIENT_ON_GAE

@kaosko kaosko added this to the 0.5.0 for T5.4 milestone Nov 12, 2014

@kaosko kaosko closed this Nov 12, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment