withSources can't be specified in build.sbt #72

Closed
kostaskougios opened this Issue Jan 3, 2012 · 5 comments

Comments

Projects
None yet
2 participants

When I do

build.sbt:
withSources:=true

I get that withSources can't be reassigned as it is a val.

Shouldn't this be configurable?

Thanks

Contributor

hseeberger commented Jan 4, 2012

I am assuming you are using sbteclipse 2.0.0. Then you can use the setting key withSource, but you have to prefix it with EclipseKeys, e.g.

EclipseKeys.withSource := true

For more details see https://github.com/typesafehub/sbteclipse/wiki/Using-sbteclipse.

Please notice that withSource has no effect yet in 2.0.0-M2, but should work in the latest snapshot version and the upcoming 2.0.0-M3.

@hseeberger hseeberger closed this Jan 4, 2012

Ok, how can I use 2.0.0-SNAPSHOT? I tried it but it can't download it.

Thanks

On 04/01/12 09:19, Heiko Seeberger wrote:

I am assuming you are using sbteclipse 2.0.0. Then you can use the setting key withSource, but you have to prefix it with EclipseKeys, e.g.

EclipseKeys.withSource := true

For more details see https://github.com/typesafehub/sbteclipse/wiki/Using-sbteclipse.

Please notice that withSource has no effect yet in 2.0.0-M2, but should work in the latest snapshot version and the upcoming 2.0.0-M3.


Reply to this email directly or view it on GitHub:
#72 (comment)

Contributor

hseeberger commented Jan 4, 2012

In the future, if you want such specific help, which is not an issue, please use the sbt mailing list and use [sbteclipse] as prefix in the subject line. Also, please provide more information about your project.

I assume that you have to add the following line to your project/plugins.sbt (or the global plugins definition file):

resolvers += Classpaths.typesafeSnapshots

Hi Heiko, thanks, I added the resolvers and now it works with sbteclipse
2.0.0-SNAPSHOT. I can now see the source files of the libraries in the
classpath.
(didn't solve my other bug entry related the resources not been in the
classpath)

My project is nothing special, I am just trying to test some stuff with
akka but got kind of stuck with sbt/sbteclipse. Please find attached the
project. I admit I am new to sbt and sbteclipse but the withSources not
working was a genuine bug of 2.0.0-M2. Also my main focus was not to
learn sbt/sbteclipse, but so far I've spend most of my time learning
those instead of akka (but then again, I've spend quite a lot of time
learning maven). I'll probably need to post my experiences on sbt
mailing list (which by the way is not working).

Btw, before opening this issue, I read all the documentation (and
googled etc) and tried to send an email to the mailing list but it
bounced back. I tried just now as well without luck (please see at the
end of this email). Then I posted a msg on scala-tools and I was adviced
to open an issue here.

Anyway, I believe a couple of full-blown simple examples of
sbteclipse/sbt, along with the wiki, would help.

Regards,

Kostas

Bounced back email from the mailing list:

Hellokostas.kougios@peerius.com,

We're writing to let you know that the group you tried to contact (simple-build-tool) may not exist, or you may not have permission to post messages to the group. A few more details on why you weren't able to post:

  • You might have spelled or formatted the group name incorrectly.
  • The owner of the group may have removed this group.
  • You may need to join the group before receiving permission to post.
  • This group may not be open to posting.

If you have questions related to this or any other Google Group, visit the Help Center athttp://groups.google.com/support/?hl=en_US.

Thanks,

Google Groups

----- Original message -----

Received: by 10.224.179.67 with SMTP id bp3mr4040068qab.5.1325672708323;
Wed, 04 Jan 2012 02:25:08 -0800 (PST)
Received: by 10.224.179.67 with SMTP id bp3mr4040066qab.5.1325672708309;
Wed, 04 Jan 2012 02:25:08 -0800 (PST)
Return-Path:kostas.kougios@peerius.com
Received: from smtp125.iad.emailsrvr.com (smtp125.iad.emailsrvr.com. [207.97.245.125])
by gmr-mx.google.com with ESMTPS id z3si43241464qcr.1.2012.01.04.02.25.08
(version=TLSv1/SSLv3 cipher=OTHER);
Wed, 04 Jan 2012 02:25:08 -0800 (PST)
Received-SPF: neutral (google.com: 207.97.245.125 is neither permitted nor denied by best guess record for domain ofkostas.kougios@peerius.com) client-ip=207.97.245.125;
Authentication-Results: gmr-mx.google.com; spf=neutral (google.com: 207.97.245.125 is neither permitted nor denied by best guess record for domain ofkostas.kougios@peerius.com)smtp.mail=kostas.kougios@peerius.com
Received: from localhost (localhost.localdomain [127.0.0.1])
by smtp42.relay.iad1a.emailsrvr.com (SMTP Server) with ESMTP id 1EEE91484FD
forsimple-build-tool@googlegroups.com; Wed, 4 Jan 2012 05:25:08 -0500 (EST)
X-Virus-Scanned: OK
Received: by smtp42.relay.iad1a.emailsrvr.com (Authenticated sender: kostas.kougios-AT-peerius.com) with ESMTPSA id D744F148189
forsimple-build-tool@googlegroups.com; Wed, 4 Jan 2012 05:25:07 -0500 (EST)
Message-ID:4F042903.4000507@peerius.com
Date: Wed, 04 Jan 2012 10:25:07 +0000
From: Konstantinos Kougioskostas.kougios@peerius.com
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20111124 Thunderbird/8.0
MIME-Version: 1.0
To:simple-build-tool@googlegroups.com
Subject: [sbteclipse] test
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Is this now working?

.

On 04/01/12 10:18, Heiko Seeberger wrote:

In the future, if you want such specific help, which is not an issue, please use the sbt mailing list and use [sbteclipse] as prefix in the subject line. Also, please provide more information about your project.

I assume that you have to add the following line to your project/plugins.sbt (or the global plugins definition file):

resolvers += Classpaths.typesafeSnapshots

Reply to this email directly or view it on GitHub:
#72 (comment)

Contributor

hseeberger commented Jan 4, 2012

Hi Kostas,

Thanks for your feedback.

In order to post to the sbt mailing list, which is a Google group, you have to register first. As there is no approval necessary, you could start posting immediately.

As far as I know Akka is still using sbteclipse 1.5.0. Of course the final 2.0 stack (Akka 2.0, Play 2.0) will use sbteclipse 2.0.0.

I understand that the documentation of sbteclipse is not yet good enough, but please notice that we are talking about work in progress. As soon as there will be a release candidate, the documentation will be finalized.

Please continue sending your experience reports (missing parts of the documentation) via the mailing list. That's very helpful for us for improving the documentation. The mailing list is the proper place, because others could also contribute their experiences.

Thanks
Heiko

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment