Skip to content
Permalink
Browse files

feat(*): change TypeScript version range to >=3.2.1 <3.5.0 (#399)

  • Loading branch information...
JamesHenry committed Apr 3, 2019
1 parent 95a948d commit a4f95d36ab6d799d7e48b7e984d1cf74a4641214
@@ -1,6 +1,6 @@
---
name: 'Default'
about: Default Pull Request Template
name: 'Standard'
about: Standard Pull Request Template
title: ''
labels: ''
assignees: ''
@@ -14,5 +14,5 @@ TypeScript version added by this PR: `{{ INSERT_TYPESCRIPT_VERSION }}`
- [ ] I have updated the range value in `packages/typescript-estree/src/parser.ts`
- [ ] I have run the existing tests to make sure they still pass, or made any required updates
- [ ] I have added new tests for the features introduced in this newer version of TypeScript
- New features tests added:
-
- New feature tests added:
- ...
@@ -74,6 +74,6 @@
"ts-jest": "^24.0.0",
"ts-node": "^8.0.1",
"tslint": "^5.11.0",
"typescript": ">=3.2.1 <3.4.0"
"typescript": ">=3.2.1 <3.5.0"
}
}
@@ -26,7 +26,7 @@ type CreateRuleMeta<TMessageIds extends string> = {
// This function will get much easier to call when this is merged https://github.com/Microsoft/TypeScript/pull/26349
// TODO - when the above rule lands; add type checking for the context.report `data` property
export function createRule<
TOptions extends Readonly<any[]>,
TOptions extends any[],
TMessageIds extends string,
TRuleListener extends RuleListener = RuleListener
>({
Oops, something went wrong.

0 comments on commit a4f95d3

Please sign in to comment.
You can’t perform that action at this time.