Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 72 lines (56 sloc) 1.721 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71
source 'http://rubygems.org'

# Declare your gem's dependencies in typus.gemspec.
# Bundler will treat runtime dependencies like base dependencies, and
# development dependencies will be added by default to the :development group.
gemspec

# Gems used only for assets and not required
# in production environments by default.
group :assets do
  gem 'sass-rails', " ~> 3.1.0"
  gem 'coffee-rails', "~> 3.1.0"
  gem 'uglifier'
end

# Database adapters
platforms :jruby do
  gem 'activerecord-jdbcmysql-adapter'
  gem 'activerecord-jdbcpostgresql-adapter'
  gem 'activerecord-jdbcsqlite3-adapter'

  gem 'jruby-openssl' # JRuby limited openssl loaded. http://jruby.org/openssl
end

platforms :ruby do
  gem 'mysql2'
  gem 'pg'
  gem 'sqlite3'
end

# And this stuff needed for the demo application.
gem "acts_as_list"
gem "acts_as_tree"
gem "factory_girl_rails", "~> 1.1.0"
gem "rails-permalink", "~> 1.0.0"
gem "rails-trash", "~> 1.1.2"

# For some reason I also need to define the `jquery-rails` gem here.
gem "jquery-rails"

# Rich Text Editor
gem "ckeditor-rails", "0.0.2"

# Alternative authentication
gem "devise", "~> 1.4.3"

# Asset Management with Dragonfly
gem "dragonfly", "~> 0.9"
gem "rack-cache", :require => "rack/cache"

# Asset Management with Paperclip
gem "paperclip", "~> 2.3.16"

# MongoDB
gem "mongoid", "~> 2.1"
gem "bson_ext", "~> 1.3"

group :test do
  gem "shoulda-context", "~> 1.0.0.beta1"
  gem "mocha" # Make sure mocha is loaded at the end ...
end

# Remember to install the Chrome or Safari extension, otherwise it doesn't
# make sense to have this here.
group :development do
  gem "guard-livereload"
  # gem "rb-fsevent"
  # gem "growl_notify"
end

gem "SystemTimer", :platform => :ruby_18
Something went wrong with that request. Please try again.