No version variable for tzinfo #28

Closed
marshallshen opened this Issue Sep 30, 2014 · 1 comment

Comments

Projects
None yet
2 participants
@marshallshen
Contributor

marshallshen commented Sep 30, 2014

In the latest release, I don't seem to be able to get package version (1.2.2) by running

TZInfo.version

or

TZInfo::Version

Is there a specific reason why the gem doesn't have such support?

Thanks!

@philr

This comment has been minimized.

Show comment
Hide comment
@philr

philr Sep 30, 2014

Member

The only reason is that it hasn't been added before (please feel free to submit a pull request).

If you are using TZInfo as a gem, then you can get the loaded version as follows:

Gem.loaded_specs['tzinfo'].version
Member

philr commented Sep 30, 2014

The only reason is that it hasn't been added before (please feel free to submit a pull request).

If you are using TZInfo as a gem, then you can get the loaded version as follows:

Gem.loaded_specs['tzinfo'].version

@philr philr added the question label Sep 30, 2014

@philr philr closed this Sep 30, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment