Gem install error on ruby 2.1.5 #40

Closed
josisusan opened this Issue Jun 24, 2015 · 1 comment

Comments

Projects
None yet
1 participant
@josisusan

Hi,

My ruby version is 2.1.5. When I install this gem using command:

gem install tzinfo -v '0.3.44'

I got this error:

ERROR:  Error installing tzinfo:
    invalid gem: package is corrupt, exception while verifying: undefined method `size' for nil:NilClass (NoMethodError) in /Users/josisusan/.rvm/gems/ruby-2.1.5/cache/tzinfo-0.3.44.gem
@josisusan

This comment has been minimized.

Show comment
Hide comment
@josisusan

josisusan Jun 24, 2015

Sorry, I didn't notice the cache folder. Deleted the cached .gem file, and re-installed with the same command. It is working fine now.

Sorry, I didn't notice the cache folder. Deleted the cached .gem file, and re-installed with the same command. It is working fine now.

@josisusan josisusan closed this Jun 24, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment