Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Realm database is empty #45

Closed
Delphian2015 opened this issue Dec 20, 2016 · 7 comments

Comments

Projects
None yet
6 participants
@Delphian2015
Copy link

commented Dec 20, 2016

Hello.

Thank you for your plugin. I am trying to use it. I see my database but the base is empty although I have a data (4 realm object classes and data in them)?
chrome

@Farasy

This comment has been minimized.

Copy link

commented Jan 2, 2017

Faced the same issue.
Don't setup a custom name for the realm or custom folder solved this.

@careful7j

This comment has been minimized.

Copy link

commented Jan 3, 2017

Thank you sir, removing line ".name("myrealm2.realm") solved my problem, but It's quite sad that we can't use custom realm database names. I.e. I need more than one db than it can become an issue.

new RealmConfiguration.Builder()
                .name("myrealm2.realm")  //Comment this line so database won't be empty anymore
                .schemaVersion(2) 
                .migration(DbUtils.migration)
                .build();
@Delphian2015

This comment has been minimized.

Copy link
Author

commented Jan 3, 2017

Yes, I deleted the name of the database, but it is not a good solution. Thank you!

@linchaolong

This comment has been minimized.

Copy link

commented Jan 5, 2017

@Delphian2015 I'm fixed the problem, you can see this.

@marafat

This comment has been minimized.

Copy link

commented Jan 19, 2017

Any plans on releasing this fix soon??

@linchaolong

This comment has been minimized.

Copy link

commented Jan 28, 2017

stetho-realm 2.0.1 is released.

edit build.gradle:

repositories {
    maven { url 'https://github.com/linchaolong/stetho-realm/raw/master/maven-repo' }
}

dependencies {
    compile 'com.facebook.stetho:stetho:1.4.2'
    compile 'com.uphyca:stetho_realm:2.0.1'
}
@zaki50

This comment has been minimized.

Copy link
Member

commented Jul 19, 2017

I've released 2.1.0 that contains the fix.
I'll close this issue.

@zaki50 zaki50 closed this Jul 19, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.