Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Move cross-submodule deps to peer dependencies #2765

Merged
merged 2 commits into from Mar 7, 2019

Conversation

Projects
None yet
3 participants
@Pessimistress
Copy link
Contributor

commented Mar 7, 2019

For #2736

Change List

  • Dependency audit for submodules
  • Update documentation

@Pessimistress Pessimistress requested review from tsherif and ibgreen Mar 7, 2019

@tsherif

tsherif approved these changes Mar 7, 2019

@ibgreen

ibgreen approved these changes Mar 7, 2019

Copy link
Contributor

left a comment

Looks good, just some small suggestions, ignore or use as you see fit.

Show resolved Hide resolved docs/get-started/getting-started.md Outdated
Show resolved Hide resolved docs/get-started/getting-started.md Outdated
Show resolved Hide resolved docs/get-started/using-with-mapbox-gl.md Outdated
Show resolved Hide resolved docs/get-started/using-with-mapbox-gl.md

Open source tile schemas include:

- [TileZen schema](https://tilezen.readthedocs.io/en/latest/layers/)

This comment has been minimized.

Copy link
@ibgreen

ibgreen Mar 7, 2019

Contributor

I constantly get questions about 3D buildings, is there a URL we could mention here?

This comment has been minimized.

Copy link
@Pessimistress

Pessimistress Mar 7, 2019

Author Contributor

It wouldn't work with our current templates, unless you use MapboxLayer. We will need a full example for that.

@@ -2,7 +2,7 @@

## Installation

First, you need to install the deck.gl (and luma.gl) frameworks
To install the deck.gl framework:

```bash
npm install deck.gl --save

This comment has been minimized.

Copy link
@ibgreen

ibgreen Mar 7, 2019

Contributor

Should we align this with the submodule system below?

This comment has been minimized.

Copy link
@Pessimistress

Pessimistress Mar 7, 2019

Author Contributor

As a quick start this is the fastest and safest way to get things going. Advanced users who want to cherry pick their dependencies can read the section below.


```bash
git checkout 6.0-release
git checkout 6.4-release

This comment has been minimized.

Copy link
@ibgreen

ibgreen Mar 7, 2019

Contributor

If this is on master, 7.0-release?

This comment has been minimized.

Copy link
@Pessimistress

Pessimistress Mar 7, 2019

Author Contributor

This will be bumped when we cut the release branch using script.

@Pessimistress Pessimistress merged commit 3735b57 into ocular-dev-tools Mar 7, 2019

3 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details
license/cla Contributor License Agreement is signed.
Details

@Pessimistress Pessimistress deleted the module-docs branch Mar 7, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.