Skip to content
Permalink
Browse files

Set the default tf version to 1.13.1

  • Loading branch information...
w4nderlust committed Mar 21, 2019
1 parent ec52e82 commit 4857e39c71c3c627e2d288ecf6b4847e546837e4
Showing with 4 additions and 4 deletions.
  1. +0 −1 README.md
  2. +3 −1 ludwig/utils/tf_utils.py
  3. +0 −1 mkdocs/docs/getting_started.md
  4. +1 −1 requirements.txt
@@ -54,7 +54,6 @@ If you don’t have Python 3 installed, install it by running:
sudo apt install python3 # on ubuntu
brew install python3 # on mac
```
If you are using Python 3.7, you have to use `tensorflow>=1.13.1` as previous versions do not support it.
You may want to use a virtual environment to maintain an isolated [Python environment](https://docs.python-guide.org/dev/virtualenvs/).

In order to install Ludwig just run:
@@ -56,7 +56,9 @@ def get_tf_config(gpus=None, gpu_fraction=1, horovod=None,
per_process_gpu_memory_fraction=gpu_fraction,
allow_growth=True)
else:
gpu_options = tf.GPUOptions()
gpu_options = tf.GPUOptions(allow_growth=True)
# allow_growth=True is needed for a weird behavior with CUDA 10
# https://github.com/tensorflow/tensorflow/issues/24828
if isinstance(gpus, int):
gpus = [gpus]
gpu_options.visible_device_list = ','.join(str(g) for g in gpus)
@@ -52,7 +52,6 @@ sudo apt install python3 # on ubuntu
brew install python3 # on mac
```

At the time of writing this document, TensorFlow is not compatible with Python 3.7, so the recommended version of Python for Ludwig is 3.6.
You may want to use a virtual environment to maintain an isolated [Python environment](https://docs.python-guide.org/dev/virtualenvs/).

In order to install Ludwig just run:
@@ -11,6 +11,6 @@ spacy>=2.0
https://github.com/explosion/spacy-models/releases/download/en_core_web_sm-2.0.0/en_core_web_sm-2.0.0.tar.gz
tqdm
tabulate>=0.7
tensorflow==1.12.0
tensorflow==1.13.1
PyYAML>=3.12
pytest

0 comments on commit 4857e39

Please sign in to comment.
You can’t perform that action at this time.