New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Volume control has no effect on audio level during phone call #105

Closed
tomoqv opened this Issue Jun 13, 2017 · 17 comments

Comments

Projects
8 participants
@tomoqv
Copy link

tomoqv commented Jun 13, 2017

Bacon 15.04/devel r27

The volume buttons or audio control in the indicator bar have no effect at all on the audio level during a phone call when a wired headset is connected. The volume indicator bar moves as expected, but the audio level stays the same.

It works playing a song from Cutespotify though.

@siucdude

This comment has been minimized.

Copy link

siucdude commented Jun 14, 2017

Same thing on Speakphone during a call..

@NeoTheThird NeoTheThird added bug and removed needs confirmation labels Jun 14, 2017

@NeoTheThird

This comment has been minimized.

Copy link
Member

NeoTheThird commented Jun 14, 2017

Yep, i can confirm it.

@Flohack74 Flohack74 changed the title Volume control has no effect on audio level with wired headset during phone call Volume control has no effect on audio level during phone call Feb 20, 2018

@fabianHAW

This comment has been minimized.

Copy link

fabianHAW commented Mar 21, 2018

same here on ut 15.04 r3. any suggestions? just tried it with uVolMan, but there is no option to change it..

@Flohack74

This comment has been minimized.

Copy link
Member

Flohack74 commented Apr 11, 2018

Hi Guys,
just wanted to update that there is finally a progress on this issue: We have a manual fix in place now, that´s being tested by me. The issues relates to adding and linking a few missing files to the device files build tree, and then compiling it into a new system image. So it´s nothing critical

As we are not planning to release an OTA for 15.04, this fix will be rolled out to a general public audience automatically only with upcoming 16.04 releases.

However, I will try to do my best to describe a hotfix in the forum´s support section, so that you can benefit from this also in 15.04

@Flohack74 Flohack74 self-assigned this Apr 11, 2018

@Flohack74 Flohack74 added this to the 16.04 OTA-4 milestone Apr 11, 2018

@Flohack74 Flohack74 added this to In Development in Ubuntu Touch Apr 11, 2018

@ghost ghost self-assigned this Apr 11, 2018

@ghost

This comment has been minimized.

Copy link

ghost commented Apr 11, 2018

A little more patience.

@Flohack74

This comment has been minimized.

Copy link
Member

Flohack74 commented May 4, 2018

@rubencarneiro from daily use I can see that your fix improved the volume control a bit. But now the issue is that by changing the volume during call it also changes the volume of the loudspeaker, making my ringtone softer or louder all the time. Somehow this is coupled together...

@NeoTheThird

This comment has been minimized.

Copy link
Member

NeoTheThird commented Jun 16, 2018

@Flohack74 Do you think you'll get a chance to work on this? If not, i'd suggest to push it to the next milestone...

@Flohack74

This comment has been minimized.

Copy link
Member

Flohack74 commented Jun 16, 2018

I am not sure, can take a look to determine how much work it is. Need to ping Ruben to see what he did in fact.

@tomoqv

This comment has been minimized.

Copy link

tomoqv commented Jun 20, 2018

This appears to be a bug on Pro 5 with xenial as well.

@NeoTheThird NeoTheThird modified the milestones: 16.04 OTA-4, 16.04 OTA-5 Jun 29, 2018

@NeoTheThird NeoTheThird moved this from In Development to Accepted in Ubuntu Touch Jun 29, 2018

@mariogrip mariogrip removed this from the 16.04 OTA-5 milestone Sep 24, 2018

@Flohack74 Flohack74 moved this from Accepted to In Development in Ubuntu Touch Nov 16, 2018

@Flohack74 Flohack74 added this to the 16.04 OTA-6 milestone Nov 16, 2018

@Flohack74

This comment has been minimized.

Copy link
Member

Flohack74 commented Nov 16, 2018

I finally got an idea how to solve this. Lemme try to get it into a test image...

Flohack74 added a commit to ubports/android_device_oneplus_bacon-1 that referenced this issue Nov 16, 2018

@Flohack74 Flohack74 moved this from In Development to Quality Assurance in Ubuntu Touch Nov 16, 2018

@Flohack74

This comment has been minimized.

Copy link
Member

Flohack74 commented Nov 16, 2018

There is a potential fix in latest devel, can you test maybe :) - 1 or 2 of you?

@NeoTheThird

This comment has been minimized.

Copy link
Member

NeoTheThird commented Nov 19, 2018

Only tested on the FP2 and it doesn't work, do you want this issue to be tagged FP2 as well, or do you want a separate issue for that @Flohack74 ?

@NeoTheThird

This comment has been minimized.

Copy link
Member

NeoTheThird commented Nov 19, 2018

The Nexus 5 is probably also affected, since it has audioflingerglue as well, if someone could test that?

Ubuntu Touch automation moved this from Quality Assurance to In Development Nov 19, 2018

@UniversalSuperBox

This comment has been minimized.

Copy link
Member

UniversalSuperBox commented Nov 19, 2018

I connected a (edit: WIRED) headset to my Nexus 5 and answered a call. The volume control rocker changed the volume of the call for my side. Seems like this does not affect the Nexus 5.

I did the same with the FP2 as well. Volume control worked as expected there, but I did need to detach and reattach the headset before the output switched from the earpiece to the headset.

@Flohack74

This comment has been minimized.

Copy link
Member

Flohack74 commented Nov 20, 2018

Please make a new issue about any other discoveries. We had this issue about the OPO missing acdbdata and mixer_paths.xml which has been resolved and which seems to have the intended resolution. While not perfect, the volume is now changeable (the change steps are to shallow atm IMHO). But its much better than before.

@Flohack74 Flohack74 closed this Nov 20, 2018

Ubuntu Touch automation moved this from In Development to Quality Assurance Nov 20, 2018

@UniversalSuperBox UniversalSuperBox added this to To do in OTA-6 QA Tracker via automation Nov 23, 2018

@WillemHexspoor

This comment has been minimized.

Copy link

WillemHexspoor commented Dec 2, 2018

Device: Nexus 4
image: 2018-W48
Volume slider during phone call with headset only works properly between roughly 60 and 100%. This means the volume changes according the position of the slider. Below around 60% the slider can be moved to zero but the volume does not decrease accordingly. Also at zero percent there is still sound audible from the other side although the headphone icon above the slider is striked through

@Flohack74

This comment has been minimized.

Copy link
Member

Flohack74 commented Dec 5, 2018

Please: Make a new bug if a bug has been closed AND its not for your device...

@UniversalSuperBox UniversalSuperBox moved this from To do to Accepted in OTA-6 QA Tracker Dec 10, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment