[IDE][Android] Android Studio is missing #302

Closed
gperdomor opened this Issue Apr 22, 2016 · 14 comments

Projects

None yet

7 participants

@gperdomor

Hi, what happen with android studio?

@LyzardKing
Collaborator

Hi,
Android studio and the sdk changed the download pages significantly.
They've been fixed in master, and will be working again in the next release.

On Fri, Apr 22, 2016, 05:18 gperdomor notifications@github.com wrote:

Hi, what happen with android studio?


You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub
#302

@Akshar-Patel

ERROR: A default framework for category Android was requested where there is none

Please release update as soon as possible.

@gperdomor

@LyzardKing any ETA for the next release? I need it :(

@LyzardKing
Collaborator

If you need you can clone the repository and install from that.
It's less than ideal, but if it can help you for the time being.

git clone https://github.com/ubuntu/ubuntu-make
cd ubuntu-make
bin/umake android
@marcinant

IMHO it's still not fixed.

Just cloned umake as described above and I got this message:

ERROR: We were expecting to find a license on the download page, we didn't.

@Akshar-Patel

@marcinant same here. This needs to be fixed.

@rakshithravi1997

I can confirm that Android Studio and Android SDK are working on the latest commit as of writing. Arduino IDE, however, isn't

@LyzardKing
Collaborator

There's already a pull request for arduino.
The issue with all these is that openjdk-7 has been removed from the
main repositories.
So we had to add openjdk-8 to every one.
From my tests, as soon as arduino is fixed everything should be
installable on 16.04

@rakshithravi1997

Good to hear! Any estimate on when it will be added to the main servers? For people who don't follow this thread should also get the update for this is a very crucial fix

@e-ht
e-ht commented Apr 27, 2016 edited

@LyzardKing where are you seeing arduino?

@LyzardKing
Collaborator

The arduino ide should work in Ubuntu 15.10 and previous versions.
In 16.04 it needs the fix in the pull request (dependency on openjdk-8)

On Wed, Apr 27, 2016, 20:35 Jared W notifications@github.com wrote:

@LyzardKing https://github.com/LyzardKing where are you seeing arduino?

umake ide arduino
usage: umake ide [-h]

{rubymine,phpstorm,idea-ultimate,pycharm,visual-studio-code,datagrip,eclipse-cpp,eclipse-php,pycharm-professional,pycharm-educational,webstorm,clion,eclipse-jee,idea,eclipse,lighttable}
...
umake ide: error: argument framework: invalid choice: 'arduino' (choose
from 'rubymine', 'phpstorm', 'idea-ultimate', 'pycharm',
'visual-studio-code', 'datagrip', 'eclipse-cpp', 'eclipse-php',
'pycharm-professional', 'pycharm-educational', 'webstorm', 'clion',
'eclipse-jee', 'idea', 'eclipse', 'lighttable')


You are receiving this because you were mentioned.

Reply to this email directly or view it on GitHub
#302 (comment)

@LyzardKing
Collaborator

Closing since all this should work in the new release (16.05)

@LyzardKing LyzardKing closed this May 4, 2016
@ctrom
ctrom commented May 19, 2016

Is there any chance of having this backported to xenial (16.04)? I see that the fix has been released for yakkety (16.10).

@LyzardKing
Collaborator

Hi,
You need to add the ppa to get the latest version.
It's updated frequently as it's easier to upload a version to a ppa.

$ sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
$ sudo apt update
$ sudo apt install ubuntu-make

This way it'll install the latest release version (at the moment 16.05)

On 19/05/2016 21:30, Christopher wrote:

Is there any chance of having this backported to xenial (16.04)? I see
that the fix has been released for yakkety (16.10).


You are receiving this because you modified the open/close state.
Reply to this email directly or view it on GitHub
#302 (comment)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment