OpenSSL error running umake ide idea-ultimate #401

Open
isatori opened this Issue Jan 25, 2017 · 1 comment

Projects

None yet

2 participants

@isatori
isatori commented Jan 25, 2017 edited

Hi,

I encountered an error regarding umake download on a different command $ umake -v ide idea-ultimate, which is a previously closed issue with no solution under "OpenSSL error running umake go #195". Here's the log:

Downloading and installing requirements
INFO: Start downloading DownloadItem(url='https://download.jetbrains.com/idea/ideaIU-2016.3.3.tar.gz', checksum=Checksum(checksum_type=<ChecksumType.sha256: 'sha256'>, checksum_value='95871c9a8aed1bd8992ff493fbc5fc31674b18ef3cd509eb8f2e5650b3419eaf'), headers=None, ignore_encoding=True, cookies=None) to a temp file
INFO: Starting new HTTPS connection (1): download.jetbrains.com
INFO: Starting new HTTPS connection (1): download-cf.jetbrains.com
ERROR: https://download.jetbrains.com/idea/ideaIU-2016.3.3.tar.gz couldn't finish download: [SSL: DECRYPTION_FAILED_OR_BAD_RECORD_MAC] decryption failed or bad record mac (_ssl.c:1977)
INFO: All pending downloads for [DownloadItem(url='https://download.jetbrains.com/idea/ideaIU-2016.3.3.tar.gz', checksum=Checksum(checksum_type=<ChecksumType.sha256: 'sha256'>, checksum_value='95871c9a8aed1bd8992ff493fbc5fc31674b18ef3cd509eb8f2e5650b3419eaf'), headers=None, ignore_encoding=True, cookies=None)] done
100% |########################################################################|
ERROR: [SSL: DECRYPTION_FAILED_OR_BAD_RECORD_MAC] decryption failed or bad record mac (_ssl.c:1977)

I believe that ubuntu make downloads in different URL's (download.jetbrains.com, download-cf.jetbrains.com) and then combine it or something which make sense because the checksum are the same, but somehow it cannot merge the two. I managed to download the IDE with the first URL (https://download.jetbrains.com/idea/ideaIU-2016.3.3.tar.gz) with no errors on a firefox browser, but the ubuntu make doesn't allow you to use the downloaded *.tar.gz as an alternative solution.

I am running Ubuntu 16.04 LTS amd64 desktop with Ubuntu make version 16.11.1 if this helps.

Regards

@didrocks
Member

Hey @isatori. I was just able to install it successfully here, do you still have that issue or that was a transient ssl one?
The error is coming from the underlying network libraries, not umake itself, it seems that it can't check for ssl certificate on your system (not the one that the brower has, but the OS itself).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment