Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Native Container: Make Android app compatible with Android 2.1 (or earlier, if possible) #89

Open
Trott opened this Issue Feb 3, 2012 · 4 comments

Comments

Projects
None yet
2 participants
Contributor

Trott commented Feb 3, 2012

The UCSF Android app seems to compile just fine against Android 2.1 but not any earlier. So, I'm setting the minimum to Android 2.1. Not sure if the native container is set to that or a later or earlier version, but it should be set to the earliest version we can be compatible with, I imagine.

Contributor

Trott commented Feb 3, 2012

Contributor

zkhalapyan commented Feb 3, 2012

What are the errors that you are getting?

Contributor

Trott commented Feb 5, 2012

It's mostly stuff about displays and hopefully-minor issues with images. Here's what I'm seeing:

If I do a clean checkout of the feature/native branch, remove the unused imports from MWFWebViewActivity.java, set the build target and minSdkVersion to SDK 7 (Android 2.1), I get this error: http://i.imgur.com/naTBE.png

If I do the same, but choose SDK 3 (Android 1.5), I get a few more like it: http://i.imgur.com/sUVOS.png Not sure that anything less than 2.1 matters much, since anything less than Android 2.1 accounts for a tiny fraction of the market. (See http://www.appbrain.com/stats/top-android-sdk-versions.)

If I do a clean checkout of the feature/native branch, remove the unused imports from MWFWebViewActivity.java, and go to Android Tools > Run Lint, I get three warnings about images that you can see at http://i.imgur.com/r0g28.png.

Thinking about this some more, I imagine it's only an issue for UCSF, where we replaced an app that ran on Android 1.5 devices (and have at least one Android 1.5 user who noticed that they can't install the new MWF-powered app). For anybody else, such a user would probably shrug and say "Oh well." But in our case, they already had an app and by replacing it with the MWF native container, they're excluded going forward.

Anyway, you should (of course) feel free to close if you think none of these issues are worth addressing, although I guess whatever the minimum required Android version is for the native container should be documented....

Contributor

zkhalapyan commented Feb 5, 2012

The main object we are using for the app is WebView, which is supported since API Level 1. The most of the issues arise from using non backward-compatible features like setting xlargeScreen = true within the Support Screens tag, which was supported after API Level 9.

Definitely agree with you that very small population still uses Android 1.5 or less. Although with not much gain, we can still try to resolve these issues and come up with a bare-bone solution that is compatible with 1.0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment