Skip to content

API: System: Requirements and Packages

Trott edited this page · 5 revisions
Clone this wiki locally

System Requirements

The codebase of the Mobile Web Framework is compatible with *NIX variants (including Redhat Linux, Debian Linux, Solaris, Mac OS X, etc.) running Apache 2 and PHP 5.1.6 and above, and it is the intent of the project to maintain full portability across all of these systems.

In addition, due to PHP's portability functions, some have reported success (with modifications to configuration files and paths) in installing the framework on Windows Server. However, at this time, the installation scripts, default file paths and the documentation on this site are preferential to *NIX, particularly Cent OS, Fedora and RHEL, so these operating systems are generally recommended.

Required Packages

The framework itself requires several packages (listed by their Redhat yum name):

  • httpd
  • php
  • php-common
  • php-devel
  • php-cli
  • php-curl
  • php-gd
  • php-xml

In addition, the following PHP directives should be enabled for best effect:

  • allow_url_fopen = 1
  • display_errors = 0
  • safe_mode = 0
Something went wrong with that request. Please try again.