Browse files

Update to 2.0.0.

  • Loading branch information...
1 parent ff6b908 commit 310a1f20b8f6d3808101367a75b896fe0f38291e @ueno committed Oct 3, 2011
Showing with 31 additions and 39 deletions.
  1. +2 −0 AUTHORS
  2. +0 −15 History.txt
  3. +19 −0 NEWS
  4. +3 −19 README.rdoc
  5. +2 −0 THANKS
  6. +5 −5 gpgme.gemspec
View
2 AUTHORS
@@ -0,0 +1,2 @@
+Daiki Ueno <ueno@unixuser.org> (wrote version 1.0)
+Albert Llop <mrsimo@gmail.com> (major rework of version 2.0)
View
15 History.txt
@@ -1,15 +0,0 @@
-=== 1.0.9 / 2010-05-21
-
-* Stop using Hoe since the maintainer sucks:
-http://rubyforge.org/tracker/?func=detail&atid=5923&aid=27112&group_id=1513
-
-=== 1.0.8 / 2009-09-07
-
-* Follow the ABI changes of GPGME 1.2.
-
- * Add bindings for gpgme_op_{export,import}_keys_start.
- * GPGME.{decrypt,verify,sign,encrypt} now calls
- gpgme_check_version() before creating a context.
- Fixes Bug#26829 reported by Sam Hall.
-
-* Use Hoe for packaging contributed by Kouhei Sutou.
View
19 NEWS
@@ -0,0 +1,19 @@
+2.0.0 October 3, 2011
+
+- Major rework mostly done by Albert Llop
+ * Add test coverage of some type.
+ * Make documentation a little bit more newbie friendly.
+ * Improve the API to be more idiomatic.
+
+1.0.9 May 21, 2010
+
+- Stop using Hoe.
+
+1.0.8 September, 2009
+
+- Follow the ABI changes of GPGME 1.2.
+ * Add bindings for gpgme_op_{export,import}_keys_start.
+ * GPGME.{decrypt,verify,sign,encrypt} now calls
+ gpgme_check_version() before creating a context.
+ Fixes Bug#26829 reported by Sam Hall.
+- Use Hoe for packaging contributed by Kouhei Sutou.
View
22 README.rdoc
@@ -1,24 +1,8 @@
= GPGME
-This README is better is better viewed through the YARD formatted documentation:
-http://rdoc.info/github/mrsimo/gpgme/master/frames for latest github version, or
-http://rdoc.info/gems/gpgme for latest gem release.
-
-== History behind this fork
-
-This project started as my Ruby Mendicant University. The idea is to give an
-overhaul to the API of this gem. As a relativelly new developer in the ruby
-world, I found the documentation not very newbie friendly, and the API somewhat
-different to the kind I'm used to in the ruby world.
-
-GPG is a very powerful tool, and this gem is implemented using the C bindings,
-making it very fast, and the only proper way to do it.
-
-My objectives are as follows:
-
-* Add test coverage of some type.
-* Make documentation a little bit more newbie friendly.
-* Improve the API to be more idiomatic.
+This README is better viewed through the YARD formatted documentation:
+http://rdoc.info/github/ueno/gpgme/master/frames for latest github
+version, or http://rdoc.info/gems/gpgme for latest gem release.
== Requirements
View
2 THANKS
@@ -5,11 +5,13 @@ it complete and free of errors.
+Ben Burkert
Carl Corliss
Jérémie Pierson
Kouhei Sutou
Kris Nuttycombe
Marc Dequènes
+Peter Meier
Rob Pitt
Rory McKinley
Sam Hall
View
10 gpgme.gemspec
@@ -1,14 +1,14 @@
Gem::Specification.new do |s|
s.name = 'gpgme'
- s.version = '1.0.9'
- s.authors = ['Daiki Ueno']
- s.date = '2011-05-09'
+ s.version = '2.0.0'
+ s.authors = ['Daiki Ueno', 'Albert Llop']
+ s.date = '2011-10-03'
s.email = 'ueno@unixuser.org'
s.extensions = ['ext/gpgme/extconf.rb']
- s.files = Dir['{lib,ext}/**/*']
+ s.files = Dir['{lib,ext,test,examples}/**/*']
s.has_rdoc = true
s.rubyforge_project = 'ruby-gpgme'
- s.homepage = 'http://rubyforge.org/projects/ruby-gpgme/'
+ s.homepage = 'http://github.com/ueno/ruby-gpgme'
s.require_paths = ['lib', 'ext']
s.summary = 'Ruby binding of GPGME.'
s.description = %q{Ruby-GPGME is a Ruby language binding of GPGME (GnuPG

0 comments on commit 310a1f2

Please sign in to comment.