Skip to content
Permalink
Browse files

Use Visual Studio 2017 in AppVeyor

Pre-VS2017 requires C89 conformity which would fail to build post-2019.11 releases of rakudo/moarvm
  • Loading branch information
ugexe committed Dec 14, 2019
1 parent 0484e30 commit 7bbc6638aa62fa5535aad77252f9a3bc61e87ce1
Showing with 2 additions and 2 deletions.
  1. +2 −2 .appveyor.yml
@@ -1,9 +1,9 @@
os: Visual Studio 2015
os: Visual Studio 2017

platform: x64

install:
- '"C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64'
- '"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build\vcvars64.bat"'
- appveyor-retry choco install strawberryperl --allow-empty-checksums
- SET PATH=C:\strawberry\c\bin;C:\strawberry\perl\site\bin;C:\strawberry\perl\bin;%PATH%
- appveyor-retry git clone https://github.com/rakudo/rakudo.git %APPVEYOR_BUILD_FOLDER%\..\rakudo

0 comments on commit 7bbc663

Please sign in to comment.
You can’t perform that action at this time.