USE_PGXS is Deprecated #4

Closed
theory opened this Issue Mar 28, 2012 · 3 comments

Projects

None yet

2 participants

@theory
theory commented Mar 28, 2012

The PostgreSQL hackers told me not to use it for any non-core extensions, and indeed, it is not mentioned in the extension docs. The PGXN client doesn't set it, so some folks have had trouble installing twitter_fdw. So I suggest removing it, and just assuming that you're always using PGXS. Or add a NO_PGXS option if you really need a way to work around it, as I've done for pgTAP.

@umitanuki
Owner

Right, and in fact I removed it from my kmeans module. Will do it soon, with the FDW fix for 9.2 new API.

@theory
theory commented Mar 28, 2012

Cool, thanks!

@umitanuki
Owner

Yet I fixed USE_PGXS option only for now. I need to look at FDW later.

@umitanuki umitanuki closed this Mar 28, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment