New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

first build failing #643

Closed
hjamaan opened this Issue Nov 7, 2015 · 3 comments

Comments

Projects
None yet
3 participants
@hjamaan
Contributor

hjamaan commented Nov 7, 2015

Hi,

My first build is failing due to internet connectivity issue (as seen in attached screen shot).

Its seems that the macro "isreachable" is returning false when t testing for connectivity, and I read in the comments that it might return false negatives.

What is the issue exactly? any troubleshooting advice is appreciated

p.s. i tried to turn off my firewall, and i am connected to github (ssh)

screen shot 2015-11-06 at 10 43 56 pm

@hjamaan hjamaan added the build label Nov 7, 2015

@Nava2

This comment has been minimized.

Member

Nava2 commented Nov 7, 2015

Does it pass if you force it to be online?
On Nov 6, 2015 22:57, "Hamoud Aljamaan" notifications@github.com wrote:

Hi,

My first build is failing due to internet connectivity issue (as seen in
attached screen shot).

Its seems that the macro "isreachable" is returning false when t testing
for connectivity, and I read in the comments that it might return false
negatives.

What is the issue exactly? any troubleshooting advice is appreciated

p.s. i tried to turn off my firewall, and i am connected to github (ssh)

[image: screen shot 2015-11-06 at 10 43 56 pm]
https://cloud.githubusercontent.com/assets/13935108/11013372/ddbd4a76-84d8-11e5-9fd3-64c980089dda.png


Reply to this email directly or view it on GitHub
#643.

@hjamaan

This comment has been minimized.

Contributor

hjamaan commented Nov 8, 2015

yes, it passes if you enforced the online condition to be true.

My concern is the checking for online connectivity. I am connected, however, this condition fails the build scripts. I am trying to pinpoint the issue here.

My assumption is that its related to the 'isReachable' macro.

@Nava2

This comment has been minimized.

Member

Nava2 commented Nov 18, 2015

This is actually caused because the server, cruise.eecs.uottawa.ca does not appear to accept PING requests.

$ ping -c 1 -t 5 cruise.eecs.uottawa.ca
PING cruise.eecs.uottawa.ca (137.122.89.92): 56 data bytes

--- cruise.eecs.uottawa.ca ping statistics ---
1 packets transmitted, 0 packets received, 100.0% packet loss

I do not have time to fix this issue, however, a quick fix is: comment out these lines, or pass -Donline=true if you know that you are in fact online.

In order to fix this, the ping command should be replaced with the <get> task and piping the error to /dev/null on *NIX and NUL on windows. The <get> performs an HTTP GET which is the same as what any other request will use (Ivy uses HTTP calls to download).

@Nava2 Nava2 assigned toulayha and unassigned Nava2 Nov 20, 2015

Nava2 added a commit to Nava2/umple that referenced this issue Dec 4, 2015

@Nava2 Nava2 closed this in 3784547 Dec 4, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment