Rubygems #1

Closed
DouglasAllen opened this Issue Jul 23, 2014 · 1 comment

Projects

None yet

2 participants

@DouglasAllen

irb(main):001:0> require 'cheri/swing'
SyntaxError: C:/jruby-1.7.11/lib/ruby/gems/shared/gems/cheri-0.5.0/lib/cheri/builder/markup.rb:283: syntax error, unexpected
':'
when String : esc(v,str)
^
from org/jruby/RubyKernel.java:1085:in require' from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:1:in(root)'
from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:55:in require' from org/jruby/RubyKernel.java:1085:inrequire'
from C:/jruby-1.7.11/lib/ruby/gems/shared/gems/cheri-0.5.0/lib/cheri/builder.rb:27:in (root)' from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:1:in(root)'
from org/jruby/RubyKernel.java:1085:in require' from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:55:inrequire'
from C:/jruby-1.7.11/lib/ruby/gems/shared/gems/cheri-0.5.0/lib/cheri/java/builder.rb:26:in (root)' from org/jruby/RubyKernel.java:1085:inrequire'
from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:1:in (root)' from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:55:inrequire'
from org/jruby/RubyKernel.java:1085:in require' from C:/jruby-1.7.11/lib/ruby/gems/shared/gems/cheri-0.5.0/lib/cheri/awt.rb:27:in(root)'
from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:1:in (root)' from org/jruby/RubyKernel.java:1121:ineval'
from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:55:in require' from C:/jruby-1.7.11/lib/ruby/gems/shared/gems/cheri-0.5.0/lib/cheri/swing.rb:27:in(root)'
from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:1:in (root)' from C:/jruby-1.7.11/lib/ruby/shared/rubygems/core_ext/kernel_require.rb:135:inrequire'
from (irb):1:in evaluate' from org/jruby/RubyKernel.java:1521:inloop'
from org/jruby/RubyKernel.java:1284:in catch' from org/jruby/RubyKernel.java:1284:incatch'
from C:/jruby-1.7.11/bin/jirb:13:in `(root)'

Or else Jack there is going to try to fix it. ;-)

@undees
Owner
undees commented Jul 28, 2014

Hi, Douglas.

Sorry about this! Cheri is Ruby 1.8-specific, so you'll need to install and run it like so:

jruby --1.8 -S gem install cheri
jruby --1.8 -S jirb

Then, the require line will run:

irb(main):001:0> require 'rubygems'
require => true
irb(main):002:0> require 'cheri/swing'
=> true

I haven't tried much further than this, so I wouldn't be shocked if parts of Cheri haven't gone out of date. But this will at least get you to the first step.

Sincerely,

Ian

@undees undees closed this Jul 28, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment