New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update all dependencies that don't break with node 8 #431

Merged
merged 1 commit into from Dec 30, 2017
Jump to file or symbol
Failed to load files and symbols.
+15 −15
Diff settings

Always

Just for now

Update coveralls to ^3.0.0

Update es5-shim to ^4.5.9
Update eslint-plugin-import to ^2.8.0
Update gh-pages to ^1.1.0
Update istanbul to ^0.4.5
Update jasmine to ^2.8.0
Update jasmine-core to ^2.8.0
Update jest to ^21.2.1
Update leven to ^2.1.0
Update minimist to ^1.2.0
Update mocha-phantomjs-core to ^2.1.2
Update offline-github-changelog to ^1.1.2
Update rollup to ^0.51.8
Update rollup-plugin-commonjs to ^8.2.6
Update rsvp to ^4.7.0
Update unexpected-magicpen to ^0.2.2

Leave these alone as they break the build in older node versions:

eslint
eslint-config-onelint
mocha (due to supports-color)
nyc
  • Loading branch information...
papandreou committed Nov 25, 2017
commit 8723a74f2dae2f53c857cd930926f3e6fdfed726
View
@@ -28,41 +28,41 @@
"detect-indent": "3.0.1",
"diff": "1.1.0",
"greedy-interval-packer": "1.2.0",
"leven": "2.0.0",
"leven": "2.1.0",
"magicpen": "5.12.0",
"unexpected-bluebird": "2.9.34-longstack2"
},
"devDependencies": {
"babel-cli": "6.26.0",
"babel-plugin-transform-runtime": "6.23.0",
"babel-preset-es2015-without-strict": "0.0.4",
"coveralls": "^2.11.9",
"es5-shim": "4.0.5",
"coveralls": "3.0.0",
"es5-shim": "4.5.9",
"eslint": "2.13.1",
"eslint-config-onelint": "1.2.0",
"eslint-plugin-import": "1.16.0",
"find-node-modules": "1.0.4",
"gh-pages": "1.0.0",
"istanbul": "0.3.16",
"jasmine": "2.2.1",
"jasmine-core": "~2.2.0",
"jest": "19.0.2",
"minimist": "1.1.1",
"gh-pages": "1.1.0",
"istanbul": "0.4.5",
"jasmine": "2.8.0",
"jasmine-core": "2.8.0",
"jest": "21.2.1",
"minimist": "1.2.0",
"mocha": "^3.2.0",
"mocha-phantomjs-core": "2.0.1",
"mocha-phantomjs-core": "2.1.2",
"mocha-slow-reporter": "*",
"node-version-check": "2.2.0",
"nyc": "10.3.2",
"offline-github-changelog": "1.1.1",
"rollup": "0.45.2",
"rollup-plugin-commonjs": "8.0.2",
"offline-github-changelog": "1.1.2",
"rollup": "0.51.8",
"rollup-plugin-commonjs": "8.2.6",
"rollup-plugin-node-globals": "1.1.0",
"rollup-plugin-node-resolve": "3.0.0",
"rollup-plugin-uglify": "2.0.1",
"rsvp": "3.0.18",
"rsvp": "4.7.0",
"serve": "*",
"unexpected-documentation-site-generator": "^4.6.1",
"unexpected-magicpen": "0.2.1",
"unexpected-magicpen": "0.2.2",
"unexpected-markdown": "^1.7.4"
},
"files": [
ProTip! Use n and p to navigate between commits in a pull request.