CLI tool for bitFlyer FX BTC
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
exe
lib/bitflyer
spec
CODE_OF_CONDUCT.md
Gemfile
Gemfile.lock
LICENSE.txt
README.md
Rakefile
bitflyer-cli.gemspec

README.md

bitflyer-cli

Gem Version Circle CI Code Climate Dependency Status

bitflyer-cli is a CLI tool for Bitflyer FXBTC.

Installation

gem install bitflyer-cli

Set the BITFLYER_API_TOKEN and BITFLYER_API_SECRET environment variable.

export BITFLYER_API_TOKEN=your-bitflyer-api-token
export BITFLYER_API_SECRET=your-bitflyer-api-secret

Usage

Commands:
  bitflyer cancel_all                                          # cancel all of orders
  bitflyer counter_trade                                       # clear all positions
  bitflyer help [COMMAND]                                      # Describe available commands or one specific command
  bitflyer order_by_best -a=amount -t=buy/sell                 # create limit order by best price in the board
  bitflyer order_by_twap -a=amount -i=second -n=N -t=buy/sell  # trade specified amount N times at specified intervals (TWAP algorithm).
  bitflyer stop_by_range r, --range=price range                # create stop order by range based on current position
  bitflyer summary                                             # show current balance information

Contributing

Bug reports and pull requests are welcome on GitHub at https://github.com/unhappychoice/bitflyer-cli. This project is intended to be a safe, welcoming space for collaboration, and contributors are expected to adhere to the Contributor Covenant code of conduct.

License

The gem is available as open source under the terms of the MIT License.