Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 70 lines (57 sloc) 1.643 kb
de7556f @parndt Using https on the source URLs
parndt authored
1 source "https://rubygems.org"
6c99891 @unixcharles Add a bundler Gemfile for testing purpose
authored
2
3 gemspec
4
de7556f @parndt Using https on the source URLs
parndt authored
5 gem 'refinerycms', git: 'https://github.com/refinery/refinerycms', branch: 'master'
6 gem 'refinerycms-i18n', git: 'https://github.com/refinery/refinerycms-i18n', branch: 'master'
6c99891 @unixcharles Add a bundler Gemfile for testing purpose
authored
7
8 group :development, :test do
9 require 'rbconfig'
10
de7556f @parndt Using https on the source URLs
parndt authored
11 gem 'refinerycms-testing', git: 'https://github.com/refinery/refinerycms', branch: 'master'
6c99891 @unixcharles Add a bundler Gemfile for testing purpose
authored
12
13 platforms :jruby do
14 gem 'activerecord-jdbcsqlite3-adapter'
15 gem 'activerecord-jdbcmysql-adapter'
16 gem 'activerecord-jdbcpostgresql-adapter'
17 gem 'jruby-openssl'
18 end
19
20 unless defined?(JRUBY_VERSION)
21 gem 'sqlite3'
22 gem 'mysql2'
23 gem 'pg'
24 end
25
26 platforms :mswin, :mingw do
27 gem 'win32console'
28 gem 'rb-fchange', '~> 0.0.5'
29 gem 'rb-notifu', '~> 0.0.4'
30 end
31
32 platforms :ruby do
33 gem 'spork', '0.9.0.rc9'
34 gem 'guard-spork'
35
36 unless ENV['TRAVIS']
37 if RbConfig::CONFIG['target_os'] =~ /darwin/i
38 gem 'rb-fsevent', '>= 0.3.9'
39 gem 'growl', '~> 1.0.3'
40 end
41 if RbConfig::CONFIG['target_os'] =~ /linux/i
42 gem 'rb-inotify', '>= 0.5.1'
43 gem 'libnotify', '~> 0.1.3'
44 gem 'therubyracer', '~> 0.9.9'
45 end
46 end
47 end
48
49 platforms :jruby do
50 unless ENV['TRAVIS']
51 if RbConfig::CONFIG['target_os'] =~ /darwin/i
52 gem 'growl', '~> 1.0.3'
53 end
54 if RbConfig::CONFIG['target_os'] =~ /linux/i
55 gem 'rb-inotify', '>= 0.5.1'
56 gem 'libnotify', '~> 0.1.3'
57 end
58 end
59 end
60 end
61
62 # Refinery/rails should pull in the proper versions of these
63 group :assets do
64 gem 'sass-rails'
65 gem 'coffee-rails'
66 gem 'uglifier'
67 end
68
58d9b85 @gwagener Minimal upgrade for Rails 4.1 compatibility.
gwagener authored
69 gem 'jquery-rails'
Something went wrong with that request. Please try again.