Chapter # 07

Microsoft Access Forms and Reports

Q. What is a form? Explain its uses and advantages. e

A window that consists of visual components is called form. Forms are used to interact
with databases through graphical user interface.

A form is constructed from a collection of individual design elements. These elements
are called controls or control objects or tools. The common elements include buttons, check
boxes, list boxes and radio buttons etc. Different elements are used for different purposes. A
textbox is used to enter data and a label is used to display message to the user.

Uses of Form
Form is used to manipulate databases easily. It can be used to:

Add data in the database
Modify data in the database
Delete data from the database
Retrieve and view data from the database
Search the required data from the database
Advantages of Form

Some advantages of using forms are as follows:
1. Easier to Use

Form can be used by the user very easily. It contains simple graphical components that
simplify the process of data manipulation.

2. User-Friendly

Forms contain graphical components that are user-friendly. The users can use these
forms by simply clicking different components with mouse.

3. No Technical Knowledge Required

A user can use manipulate databases without any technical knowledge of databases.
The visual components enable the user to interact with the user to interact with the database
without writing technical statements.

4, Time Saving

In some situations, forms require less time to enter data in tables. Access_ provides
master-detail form that is used to entered many records at one time.

5. Flexibility
MS Access provides diffegent types of forms to display data in different styles.
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Q. Discuss different types of forms in MS Access. i BC’ ‘d-

MS Access provides the following 3 ﬁ of qng\né: M”;:L Q‘ ‘c\w\ ©
1. Columnar Form A& Yécsg &N 2~ Tabular Form. A
3. Datasheet Form Yéco od- e 4. Justified Form On & [€<0¢ -
1
1. Columnar Form one R ™ Cne h e

Columnar form is used to display one record at a time. It displays textboxes and labels.
The textboxes represents the fields of table or query. The labels represent the names of fields.

Columnar form provides different buttons to navigate through different records at the
bottom. The following example displays a-columnar form:

#9 Students

2. Tabular Form

Tabular form is used to display many records at one time. It displays records as a table.
Each row in this form displays one record of the table. The labels are displayed on the top of
each ¢olumn, Tabular form provides different buttons to navigate through different records
at the bottom. The following example displays a tabular form:

il 9 Students?

3. Datasheet Form ks '

Datasheet form is used to display many records at one time. It displays records in
datasheet view of Access. Each row in this form displays one record of the table. The labels
are displayed on top of each column. Datasheet form provides different buttons to navigate
through different records at the bottom. The following example displays a datasheet form:
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4. Justified Form

Justified form is used to display one record at a time. The fields are justified according
the form window. The labels are displayed on the top of each column.

Justified, form provides different buttons to navigate through different records at the
bottom. The following example displays a justified form:

&3 Students3
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Q. Explain the procedure to create form by using wizard.

The procedure to create form by using wizard is as follows:
1. Open the database.
2. Click on Forms button in Objects list.
3. Double click Create form by using wizard. The wizard will appear:

4. Select any table from Tables/Queries list box. The fields of the selected table will
appear in Available Fields box.
Click on any field to include in the form.

Click on __.l button. The field will move to Selected Fields box. OR click on ._E_J
button to include all fields in the form.

7. Cuckon Next button.

8. Select any layout for the form.

9. Click Next button.

10. Select any style for the form.

11. Click Next button. The following window will appear:

IR ;-_‘“
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S studyplusplus.com 5



12. Enter any title.
13. Select Open the form to view or enter information radio button.
14. Click Finish button. The form will appear as follows:

#3 Students

Q. Explain the procedure for creating form in design view.
Form Creation in Design View

Forms can be created in design view using different controls. This method allows the
user to design the form according to his particular requirements. A toolbox is available in
design view that provides different control such as textboxes and buttons etc.

The following procedure is used to create a form in design view:

1. Click New button on the form database window.

2. Select Design View and choose table or query to which the form will be associated.
3. Select View > Toolbox from menu bar to view the floating toolbar with additional
options.

! ek Tl._u 4]tr'
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| text box
option group ‘ " "';:,:‘3 toggle button
option button Qisl:"ﬂq check box
combo box ir\ EEI EE Est box
command d __l rp image
unbound object frame I . [.E bound objact frame

page break -"

| tab control
subform/subreport " 3| .}‘;‘ ne
rectangle ' 4l more controls...

4. Add controls to form by clicking and dragging field names from Field List floating
window. MS Access creates a text box for the value and label for the field name. OR
Double-click Field List window's title bar and drag all of the highlighted fields to the
form to add controls for all of the fields in Field List.

Q. Explain the procedure to add new record through forms.

The following procedure is used to add new records through forms:

1. Open the database.
2. Click on Forms button in Object list.
3. Double click the form to open.
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4. Click the New Record button B The fields of form will become empty.

E‘v Sludenls
———

5. Enter new data in the ﬁelds
6. Close the form. The data entered in fields will be saved automatlcally

Q. Explain the procedure to edit records through forms.
The following procedure is used to edit records through forms:

Open the database.

Click on Forms button in Object list.

Double click the form to open.

Go to the record to be edited by using navigation buttons at the bottom.
'Change the contents of the fields.

Close the form. The changes will be updated automatically.

DO PN

Q. Discuss different options for editing forms in MS Access.
The follow options are helpful for modifying forms in Design View:

1. Grid lines

MS Access displays a series of lines and dots in Design View to align form elements
easily. This option can turned on and off by selecting View > Grid.
2. Snap to Grid

It is used to align form object to the grid. The option can be turned on and off from
Format > Snap to Grid.
3. Resizing Objects

The form objects can be resized as follows:

» Click and drag the handles on the edges and corners of the element with mouse.

4. Change Form Object Type
The type of the form can be changed easily without creating a new form. The form
type can be changed as follows:
« Right click on the object with the mouse.

e Selecting Change To option.
¢ Select an available object type from the list.

5. Label/Object Alignment

Each form object and its corresponding label are: bounded. Both move together when
any of them is moved with the mouse. The user can change the position of the object and
label in relation to each other. The user can click and drag the large handle at the top, left
corner of the object or label for this purpose.
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6. Tab Order

The control moves from one tool to another on a form when the user presses Tab key.
The sequence in which the control moves on the form is called tab order. This option is used
to alter the tab order of objects on form. The user can change the order as follows:

e Select View > Tab Order... from menu bar.
Click the gray box before the row whose tab order is to be changed.
e Drag it to a new location and release the mouse button.

7. Form Appearance
The form appearance can be changed as follows:
Click Fill/Back Color button on formatting toolbar and click any color on palette.
Change the color of individual form objects by highlighting the object and selecting a
color from Font/Fore Color palette on formatting toolbar.
e The font and size, font effect, font alignment, border, border width and special effect
can also be modified using formatting toolbar.

FiVBack Line/Border Spedial
Color Effects

Line/Border
Color Width

8. Page Header and Footer
Headers and footers added to a form will only appear when it is printed. This option
can be used as follows: |

Select View > Page Header/Footer on the menu bar.

Select Insert > Page Numbers to add Page numbers to these sections.

Select Insert > Date and Time... to add date and time.

Select View > Page Header/Footer to hide these sections from view in Design View.

Q. What are List Boxes and Combo Boxes? Explain the procedure of adding

these objegts to a foxm.
List Box \/‘;7 s i

List box is used to display a list of item in forms. The user can select the desired item
from the available items. The user can select one or multiple items. List box occupies a
specified space on the form. A scrollbar appear in the list box if the number of items are more

than the available space.
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Combo Box

Combo box is used to display a list of item in forms. It occupies less space than list box.
It consists of a textbox and a dropdown list. The user can select the desired item from the
combo box. The values in a combo box are not visible. Combo box contains an arrow on the
right side. The user can click on the arrow to see the list of all available items.

Combo Box List Box

l Academic 3 Bl Academic 3 5
: Ben Hill Griffin il Hall
~ Reed Hall ~|

|
Adding List Box and Combo Box to Form
The following procedure is used to add a list box or combo box to a form:
Open the form in Design View.
- Select View > Toolbox to view the toolbox.
Make sure that Control Wizards button is pressed.
Click the list or combo box tool button and draw the outline on form. The combo box
wizard dialog box will appear.
Select source type for the list or combo box values and click Next >.
The next option depends on the selected choice in the first dialog box. The following
box will be displayed if the user selected look up values from a table or query.

Combo Rox Wizaid

o o il o

o v

Select the table or query from which the values of the combo box will come.
Click Next > and choose fields from the table or query.
Click Next >.

. Set the width of combo box by clicking and dragging the right edge of column.
. Click Next >, :

Combaor Box Wizard

= =0 0N
-o .

12. The next dialog box tells Access what to do with the value that is selected. Choose
"Remember the value for later use" to use the value in a macro or procedure (the
value is discarded when the form is closed) OR select the field in which the value
should be stored.
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13. Click Next >.
14. Type the name that will appear on the box's label.

15. Click Finish.

Q. What are check boxes and option buttons? Explain the procedure of
adding these objects to a form.

Ch_eckbox

Checkbox is used to display yes/no, true/false or on/off option to the user. It is used
when the user can select one or multiple options at the same time. The user can select any or
all values from a group of check boxes. The user can select a checkbox by clicking on it. A tick
sign v appears on the checkbox when the user selects it. A checkbox can be deselected by
clicking it again. An unselected check appears as blank.

Radio Button

Radio button is also known as option button. It is used to display yes/no, true/false or
ony/off option to the user. It is used when the user can select only one option from a group of
radio buttons. The user can select a radio button by clicking on it. A dot sign ® appears in the
radio button when the user selects it. A radio button can be deselected by clicking it again.
An unselected check appears as blank.

Adding Checkbox and Radio Button to Form

The following procedure is used to add a checkbox or option group to a form

1. Click Option Group tool on toolbox and draw the area where the group will be
placed on form with mouse. The option group wizard dialog box will appear.

2. Enter labels for the options.

3. Click the tab key to enter additional labels.

4. Click Next > after finishing labels.

(
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Select a default value if there is any and click Next >.
Select values for the options and click Next >,
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7. Choose what should be done with the value and click Next >.

_ FENR——_ |

8. Choose the type and style of the option group and click Next >.

9. Type the caption for the option group and click Finish.

Q. What is a command button? Explain the procedure to add a command
button to a form.

A command button is used to execute different commands by clicking on it. The
caption of the command button indicates the type of command executed by the button.

Adding Command Button to Form
The following procedure is used to add a command button to a form:

1. Open the form in Design View.

2. Ensure that Control Wizard button on the toolbox is pressed.

3. Click the command button icon on toolbox and draw the button on the form. The
Command Button Wizard will appear.

4. The action categories are displayed in the left list on first dialog window. The right

list displays the actions in each category.

Select an action for the command button and click Next >.

The next few pages of options will vary based on the selected action. Continue

selecting options for the command button.

Choose the appearance of button by entering caption text or selecting a picture.

Check Show All Pictures box to view full list of available images.

Click Next >. -
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10. Enter a name for the command button and click Finish to create the button.
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Q. What is a sub-form? List different methods of creating subforms.

A subform is a form that is placed in a parent form. The parent form is also.called
main form. Subform is also known as child form. Subforms are particularly useful to display
data from tables and queries with one-to-many relationships. '

The following example displays data on the main form from an item information table.
The subform contains all orders for that item. The item record is the one part of one-to-many
~relationship and orders are many side of the relationship. It means that many erders can be
placed for the one item.
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The subforms can be created in three ways:

e Creating a form and subform at once
e Creating subform using Subform wizard
e Creating subform using drag-and-drop method

Q. Explain the procedure of creating a form and subform at once.

This this method is used if no form has already been created. The main form and
subform can be created automatically using the form wizard if:

e Table relationships are set properly OR
¢ A query involving multiple tables is selected.

For example, a relationship can be set between a table that contains customer
information and a table that contains customer orders. The orders for each customer can be
displayed together using a main form and subform.

The following procedure is used to create a subform within a form:

Double-click Create form by using wizard on database window.

2. Select the first table or query from which the main form will display data from
Tables/Queries menu.

3. Select fields that should appear on form by highlighting the field names in Available
Fields list on left and clicking single arrow > button OR click double arrows >> to
choose all of the fields.

4. Select another table or query from Tables/Queries drop-down menu and choose the
fields that should appear on form. .

Click Next after selecting all fields.

Select Form with subform(s) if the forms should appear on same page OR Linked

forms if there are many controls on main form and a subform will not fit.

7. Click Next.

£
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8. Select a tabular or datasheet layout for the form and click Next.

9. Select a style for the form and click Next.

10. Enter the names for the main form and subform.

11. Click Finish to create the forms. New records can be added in both tables or queries
at once by using the new combination form.

Q. Explain the procedure of creating a subform using subform wizard..

If main form or both forms already exist, subform wizard can be used to combine the
forms. The following procedure is used to create a subform using subform wizard:

1. Open main form in Design View.

2. Make sure that Control Wizard button £222! on the toolbox is pressed.

3. Click Subform/Subreport icon on toolbox and draw the outline of subform on
main form. The Subform Wizard dialog box appears when mouse button is released.

4. Select Use existing Tables and Queries if the subform has not been created yet. OR
select the existing form that will become the subform.

5. Click Next.
6. The next dialog window will display table relatlonshnps assumed by MS Access
Select one of these relationships or define different relationship.

7. Click Next.

8. Enter the name of subform and click Finish.

Q. Explain the procedure of creating subform using drag-and-drop method.

This method is used to create subforms if two forms already exist. The relationships of

tables must have already been set. The following procedure is used to create subform using |
drag-and-drop method:

1. Open main form in Design View.
2. Select Window > Tile Vertically to display database window and form side-by-side.

& studyplusplus.com 5



3. Drag form icon beside the name of subform on detail section of main form design.

Q. Explain the procedure of creating multiple-page forms using tabs.

A form that consists of multiple tabs is known as multiple-page form. Each tab in this
form contains different page. When a tab is clicked, a different page appears. Tab controls are
used to create multi-page forms easily.

‘The following procedure is used to create a tab control:
Click Tab Control icon on toolbox and draw control on the form.
Add new controls to each tab page

Click the tabs to change pages.
Existing form controls cannot be added to the tab page by dragging and dropping.

Right-click on the control and select Cut from shortcut menu. _
Right-click on the tab control and select Paste. The controls can then be repositioned

on the tab control.

PPN e

7. Right-click in the tab area and choose Insert Page or Delete Page to add new tabs or

delete tabs.
Right-click on the tab control and select Page Order to reorder the tabs.

Double-click on a tab and change Name property under Other tab to rename tabs.

\©

Q. What is conditional formatting? Explain with example,

The conditional formatting is a special type of formatting. It is performed when a
particular condition is met. This formatting depends on control's value and can be added to

textboxes, lists and combo boxes. Conditional formatting can be set up to three conditional
formats. The following procedure is used to add conditional formatting to a control element:

1o Select the contiol on which the formatting is to be applied.

2. Select Format > Conditional Formatting.
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3. Select one of the following condition types under Condition 1:

* Field Value Is applies formatting based on the value of control. Select a comparison
type from the second drop-down menu and enter a value in the final text box.

* Expression Is applies formatting if the expression is true: Enter a value in text box
and the formatting will be added if the value matches the expression.

e Ficld Has Focus will apply the formatting as soon as the field has focus.
Click Add >> button to add additional conditions.

Click Delete... and check coriditions to erase to delete conditions.

o s
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Q. How can a textbox be used as password field in MS Access?

A textbox can be used as password field by modifying the properties of the textbox.
Each character should appear as an asterisk as the user types information in textbox. The
aestrisks appear in the textbox as the user types in it. However, the actual characters will be
saved in the database instead of asterisks. The following procedure is used to use a textbox as
password field:

1. Select the text field in Design View.

2. Click Properties.

3. Select Data tab.

4. Click in Input Mask field and click button [...].

5. Choose Password from list of input masks and click Finish.

Q. What is procedure of éhanging the type of a control?

The type of a control can be changed without deleting it. The change of type saves
time. the user does not have to delete a control and create a new control of different type. It is
not possible to convert the types of all controls. Only limited controls can be converted to

other type of controls. The following procedure is used to change the type of a control:

1. Select the control on the form in Design View.
2. Choose Format > Change To from the menu bar.
3. Select one of the control types that is not grayed out.

Q. Briefly describe the procedure of defining multiple primary keys.
The following procedure is used to define composite primry keys:

1. Move the mouse over the gray column next to the field names and note that it
becomes an arrow.,

2. Click the mouse, hold it down and drag it over all fields that should be primary keys
and release the button.

3. Click the primary key button.
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Q. What is report? Discuss its uses.

Reports are the output of a database-application. The user can generate different types
of reports by manipulating the database. The information on the reports is arranged in
different styles. The information displayed on the report can be from one or multiple tables
or queries. The reports may contain graphs and charts etc.

The user cannot edit the data displayed on the reports. The user also cannot input data

in reports. The reports are generated for printing purpose. They can also be displayed on
screen and stored on the disk.

Uses of Reports
The reports are basically used for the following purposes:

Reports present the required information in formatted style.

Reports provide flexibility to present the same data in different ways.
Reports can display information with graphics and charts etc.
Reports are very important in making important decisions.

Reports can be used to improve the database application.

e Reports can display the result of a query.

Q. What are the standard types of reports in MS Access? °

The standard types of reports in MS Access are as follows:

1. Columnar Reports

The columnar reports display the values of each field in each record of a table or query
in one long column of text boxes. The labels indicate the name of the field. The text box to.the
right of label provides the values. The columnar report spreads the information for a single
record over many rows.

2. Tabular Report

The tabular reports provide a column for each field of the records in rows under
column header. Additional pages are printed in sequence if columns do not fit on one page.

Q. What is difference between form and report?

Form and report are important part of a database application. These are connected
with one more tables. The main difference between a form and report is as follows:

Form Report

The basic purpose of form is to input data | The basic purpose of report is to display dafa

in tables. from tables.

The data in form can be deleted. The data in report cannot be deleted.

The data in form can be modified. The data in report cannot be modified.

The forms are used on computer screen The reports are normally used in printed form

only. on the paper.

The data in form cannot be formatted. The data in report can be formatted in different
styles.

The user can add new data through form. | The user cannot add new data through report.
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Q. How is AutoReport used to generate a report?

AutoReport creates a columnar report based on specified table or query. The following
procedure is used to create a report using AutoReport:

Ul W N

6.
v

Open the desired database.

Click on Report button from Objects list.

Click on New button. New Reports dialog box will appear.

Select columnar or tabular report option.

Click on the list box at the bottom of the dxalog box. A list will appear.

New Report

This wizard autometicaly” . -|!
r.mtuaculmmurt. '

Select the desired table or query.
Click OK button. The report will appear.

The format of the report output is very basic. MS Access does not prdvide any

formatting of the page header or footer. The user can modify the report in design view.
Saving and Closing an AutoReport

The AutoReport is not saved to the database automatically. The following procedure is

used to save the report:

1.
2
3

Select File > Close. You are prompted to save the report
Click Yes. The Save As dialog box will appear.
Enter a name and click OK. The report is saved to the Database Window.

Q. Explain the procedure to create single-table report using report wizard.

ot s

The following procedure is used to create a single-table report using report wizard:

Open a database and click on Reports button in Object list.

Double click Create report by using wizard. The report wizard will appear..

Select a table from Tables/Queries list box. The fields of the selected table or query
will appear in Available Fields box.

Click on any field to include in the report.

Click on £ button. The field will move to Selected Fields box. OR

Click on Eﬂ button to include all fields in the report.

Click on Next button.

Select any field to specify grouping level if necessary.

Click Next button. The next window will appear.

Select any field according to which data record will be sorted in report.

. Click Next button.
. Select Iayout option and orientation option.
. Click Next button.

Select any style for the report.

. Type the name of the report.

Click Finish button. The report will appear.
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Q. Explain the procedure for creating two-table report using Report wizard.
The following procedure is used to create a two-table report using report wizard:

1. Open a database.

2. Click on Reports button in Object list.

3. Double click Create report by using wizard. The report wizard will appear.

4 Select a table from Tables/Queries list box. The fields of the selected table or query
will appear in Available Fields box.
Click on any field to include-in the report.

5
6. Click on E’ﬁ button. The field will move to Selected Fields box. OR
7
8

Click on ﬁ_ button to include all fields in the report.
. Select the second table from Tables/Queries list box.
9. Move the fields of second table in Selected Fields box.
10. Click on Next button.
11. Select any field to specify grouping level if necessary.
12. Click Next button. The next window will appear.
13. Select any field according to which data record will be sorted in report.
14. Click Next button.
15. Select layout option and orientation option.
16. Click Next button.
17. Select any style for the report.
18. Type the name of the report.
19. Click Finish button. The report will appear on the screen.

Q. What is the procedure of creating a report in Design View?
The following procedure is used to create a report in Design View:

Click New button on Reports Database Window.
Highlight Design View and choose the data source of report from drop-down menu.
Click OK.
A blank grid with a erld Box and form element toolbar will appear. It is similar to
Design View for forms.
Design the report. For example, double-click the title bar of Field Box to add all fields
to the report at once.
_ Use the handles on the elements to resize them.
Move them to different locations.
Modify the look of the report by using options on formatting toolbar.
Click Print View button at the top left corner of the screen to preview the report.

MY e NP
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Q. How are reports printed?
The following procedure is used to print reports:

1. Select File > Page Setup to modify page margins, size, orientation and column setup.
2. Select File > Print from the menu bar OR click Print button on toolbar.
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Q. What is linking? How can an ob]ect from other database be linked in
MS Access?

The process of linking in MS Access creates a link to an object in another database. The
table is not copied to the current database. The following procedure is used to create a link:

1. Open the destination database.
2. Select File > Get External > Link Tables... from the menu bar.
3. Choose the database in which the table is located and click Link. A window listing

the tables in the database will appear.
4. Highlight the table or tables that should be linked and click OK. A link to the table
will appear in Database Window as a small table icon preceded by small right arrow. -

Q. What is a switchboard? Write the procedure to create a switchboard in
. MS Access.

Switchboard

A switchboard is a form that is used to navigate database and perform different tasks
in database application. It is contains user-defined commands with buttons, labels, images or
hyperlinks. These commands. invoke different actions to carry out various tasks such as
opening forms, running queries or printing reports etc.

Creating Switchboard
The following procedure is used to create a swichboard in MS Access:

1. Open the Access database.
2. Select Tools > Database Utilities > Switchboard Manager.
3.

If no Switchboard form exists, Access will display a message tellmg you that no
Switchboard exists and will ask if you want to create one. :
4. Click Yes to display Switchboard Manager screen.
5. Click Edit to edit options.
6. Change Switchboard default name from Main Switchboard to any other name.
7. Click New to display Edit Switchboard Item dialog box.
8. Type a brief description of the first item to be added in Text field.
9. Select the appropriate option from the drop-down list in Command field.
10. If you choose Open Form In Edit Mode, the Switchboard Manager will display a list
of database's forms.
11. Choose the form and click OK.
12. Repeat this process until all items are added to Switchboard form.
. 13. Click Close.

A second option can be given to users to close Switchboard besides Close box. A new
item can be created named Exit. It can be associated with command Exit Application.

Q. Write the procedure of running switchboard in MS Access.
The following procedure is used to run switchboard in MS Access:

1. Right-click on database window and choose Startup from context menu.
2. Click drop-down arrow for Display Form/Page option.
3. Choose Switchboard and click OK. The next time you open the database, MS Access

will run the Switchboard form.

& studyplusplus.com 5



Q. What are keyboard shortcuts? List different keyboard shortcuts used in

MS Access.

Keyboard shortcuts are the combination of keys that are used to perform different
tasks. They can save time and the effort of switching from keyboard to the mouse for
executing simple commands. The list of important keyboard shortcuts is as follows:

| Action | Keystroke | | Action | Keystroke |
Database actions Editing

Open existing database CTRL+O Select all CTRL+A

Open a new database CTRL+N Copy CTRL+C

Save CTRL+S Cut CTRL+X

Save record SHIFT+ENTER Paste CTRL+V

Print CTRL+P Undo CTRL+Z

Display database window | F11 Redo CTRL+Y

Find and Replace CTRL+F Find CTRL+F

Copy CTRL+C Replace CTRL+H

Cut CTRL+X Spell checker F7

Paste CTRL+V Toggle between Edit mode | F2

Undo CTRL+Z and Navigation mode

Help L. Open window for editing SHIFT+F2

Toggle between Formand | F5 large content fields

Design view Switch from current field to | ESC

s current record

Insert line break in a memo | CTRL+ENTER Navigating Through a datasheet

field Next field [ TAB

Insert current date CTRL+; Previous field SHIFT+TAB

[nsert current time CTRL+: First field of record HOME

Copy data from previous CTRL+' Last field of record END

record Next record DOWN

Add a record CTRL++ ARROW

Delete a record CTRL+- Previous record UP ARROW
First field of first record CTRL+HOME
Last field of last record CTRL+END

Short Questions

Q.1. What is form?

A window that consists of visual components is called form. Forms are used to interact
with databases through graphical user interface.

Q.2. How is a form constructed? .

A form is constructed from a collection of individual design elements. These elements
are called controls or control objects. The common elements include buttons, check boxes,
list boxes and radio buttons etc. ‘
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Q.3. List out some uses of form.

Form is used to manipulate databases easily. It can be used to add data in the database,
modify data in the database, delete data from the database, retrieve and view data from the
database and search the required data from the database.

Q.4. Write some advantages of form.
e Easier to Use and User-Friendly
e No Technical Knowledge Required
e Time Saving
o Flexibility
Q.5. List different types of forms in MS Access.
e Columnar Form
e Tabular Form
e Datasheet Form
e Justified Form
Q.6. What is the use of columnar form?

Columnar form is used to display one record at a time. It displays textboxes and labels.
The textboxes represents the fields of the table or query. The labels represent the names of the
fields.

Q.7. Write the use of tabular form.

Tabular form is used to display many records at one time. It displays records as a table.
Each row in this form displays one record of the table.

Q.8. Write the use of datasheet form.

Datasheet form is used to display many records at one time. It displays records in
datasheet view of Access. Each row in this form displays one record of the table.
Q.9. Why is a list box used in forms?

List box is used to display a list of item in forms. The user can select the desired item
from the available items. The user can select one or multiple items.
Q.10. Can you think of any advantage of using a list box in forms?

An advantage of using list box is that it occupies a specified space on the form. A
scrollbar appear in the list box if the numbers of items are more than the available space.
Q.11. How is combo box used? '

Combo box is used to display a list of item in forms. It consists of a textbox and a
dropdown list. The user can select the desired item from the combo box. Combo box contains
an arrow on the right side. The user can click on the arrow to see the list of all available items.
Q.12. What are check boxes? . '

Checkbox is used to display yes/no, true/false or on/off option. It is used when the
user can select one or multiple options at the same time. The user can select any or all values
from a group of check boxes. The user can select a checkbox by clicking on it.

Q.13. Differentiate between combo box and List box.

Combo box occupies less space than list box. It consists of a textbox and a dropdown
list. Combo box contains an arrow on the right side. List box occupies a specified space on
form. A scrollbar appear in list box if the number of items are more than the available space.

Q.14. State the purpose of radio button.

Radio button is also known as option button. It is used to display yes/no, true/false or
on/off option to the user. It is used when the user can select only one option from a group of
radio buttons. The user can select a radio button by clicking on it.
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Q.15. Distinguish between checkbox and radio button.

Checkbox is used when the user can select one or multiple options at the same time.
The user can select any or all values from a group of check boxes. Radio button is used when
the user can select only one option from a group of radio buttons.

Q.16. Which control is used to execute commands in MS Access forms?

A command button is used to execute different commands by clicking on it. The
caption of the command button indicates the type of command executed by the button.
Q.17. Define sub-form.

A subform is a form that is placed in a parent form. The parent form is called the main
form. Subforms are particularly useful to display data from tables and queries with one-to-
many relationships.

Q.18. Do you think the sub-forms are useful?
Subforms are particularly useful to display data from tables and queries with one-to-
many relationships.
Q.19. List different methods of creating sub-forms.
e Creating a form and subform at once
¢ Creating subform using Subform wizard
¢ Creating subform using drag-and-drop method
Q.20. Can you apply the formatting that depends on control's value?

Yes, the conditional formatting is a special type of formatting that depends on the
control's value. It can be added to text boxes, lists, and ‘'combo boxes. The conditional
formatting can be set up to three conditional formats.

Q.21. How can a textbox be used as password field in MS Access?

A textbox can be used as password field by modifying the properties of the textbox.
Each character should appear as an asterisk as the user types information in textbox. The
aestrisks appear in the textbox as the user types in it.
Q.22. Why is the type of a control changed?

The type of a control can be changed without deleting it. The change of type saves
time. the user does not have to delete a control and create a new control of different type. It is
not possible to convert the types of all controls.

Q.23. What are reports?

Reports are the output of a database application. The user can generate different types
of reports by manipulating the database. The information on the reports is arranged in
different styles. The reports may contain graphs and charts etc.

Q.24. List some uses of reports.
* Reports present the required information in formatted style.
» Reports provide flexibility to present the same data in different ways.
e Reports can display information with graphics and charts etc.
Q.25. List some standard types of reports in MS Access?
e Columnar Reports
» Tabular Report
Q.26. What is linking?

The process of linking in MS Access creates a link to.an-object in another database. The

table is not copied to the current database.
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Q.27. Which type of form is used to navigate database?

A switchboard is a form that is used to navigate database and perform different tasks
in database application. It is contains user-defined commands with buttons, labels, images or
hyperlinks.

Q.28. What are keyboard shortcuts?
Keyboard shortcuts are the combination of keys that are used to perform different

tasks. They can save time and the effort of switching from keyboard to the mouse for
executing simple commands.

Q.29. Differentiate between form and report?

The main difference between form and report is that form is used to input data in
database. The report is used to display data from tables.
Q.30. Which types of methods can be used to create a report?

A report can be used by using different methods like using wizard and AutoReport.
Q.31. Which two database objects can be used to create a report?

Tables and queries are two objects that can be used to create a report.

Multiple Choice

1. Forms are designed to:

a. Input data b. Manipulate data

¢. Accept change d. All
2. A form that contains a sub form is called: -

a. Form b. Main form c. Report d. None
3. Youcan drag bar to move property sheet window around screen:

a. Title bar * b Status bar c. Scroll bar d.All
4. How many are basic layouts of forms in Microsoft Access?

a.2 b.3 c.4 d.5
5. The forms are end of our database in Microsoft Access

a. Back b. Front c.Bothaand b - d. None
6. Which Auto form displays one record at a time?

a. Tabular b. Columnar

_c. Datasheet d. Justified

7. A report that provides a column for each field of the records in rows under the
column header is know as:

a. Tabular report b. Columnar report
c. Datasheet report d. Justified report
8. Which of the following can be previewed on the screen before printing?
a. Report . b. Form c. Subform d. None

9. Which of the following is used to retrieve data from database and represent it to
the user in a formatted way?

a. Report b. Form c. Query d. Table
10. How many are layout of report?
a.?2 b.3 c.4 d.5
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11. What is the function of a Form in MS Access?

12.

13.

14.

15.

16.

17.

18.

p i

20.

21.

22,

23,

24.

a. View one record at a time b. Add new data

c. Change existing data d. All

Which view can be used to enter or modify data in the underlying table?
a. Form view b. Table Design view

c. Form Design view d. New Form view

Which of the following is used to create and modify a form?

a. Form view b. Table Design view

¢. Form Design view d. New Form view

A subform can be created using:

a. Drag and drop Method b. The Form Wizard

c. subform wizard d. All

A form within another form is called:

a. Sub-form - b. Main form

¢. Multi-form d. None

All of the following are form layouts EXCEPT?

a. Tabular b: Columnar

c. Justified d. Relationship

How many form layouts are provided by MS Access?

a.2 b.4 : c.6 d. 8
When displaying a sub-form within a main form, which form is based on the
primary table?

a. Neither main form nor sub-form

b. The sub-form

c. The main form

d. Both the main form and the sub-form

A report may be based on:

a. A table but not a query

b. A query but not a table

c. Both a table and a query

d. None of these _

Which of the following is NOT a function of report?

a. Display data b. Edit data

c. Output of database application d. Print data

A single rceport can display data from: :

a.One table b. Many tables

c.Bothaand b [ d. None of these

Which type of report lists every field for every record in a single column?
a. Tabular report g b. Summary report

c. Columnar reports d. All of these

Which of the following options is used for editing forms in MS Access?
a. Grid lines b. Snap to Grid

c. Resizing objects d. All

Which of the following is used to display a list of items in forms?

a, List box b. Combo box

c. Bothaand b - d. Neither anor b
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25. Which of the following is used to display yes/no values?

a. Checkbox b. Option button

c.Bothaand b d. None

1. d 2. b 3. a 4. c S b
6. b 7. 'a 8. a 9. a 10. b
11. d 12, a 13. ¢ 14. d 15, a
16. d 17. b 18. ¢ 19. ¢ 20. b
21. ¢ 22, ¢ 23.-d 24, ¢ 25. ¢

Ul W=

-
Be®N

Fill in the Blanks

Forms are used to and data in database.

The easiest and quick way to create a form in Microsoft Access is by using______

is used to display multiple records at a time in tabular format.

A is a form that is displayed within the main form.

There are basically layouts of forms in Microsoft Access.

The objectis used only to retrieve data from the database and display it

on screen or print it on the printer.

can compare, summarize and subtotal large set of data.

Three report layouts In MS Access are , and : .

Reports are finished result of data stored in adtpbase trough formsas ________end.
retrieve data from database and present it to the user in a formatted way.

Enter, view, modify or delete Wizard

Tabular form 4. sub-form Four

Report ‘ 7. Report Columnar, Tabular,Justified

= ofon|no

DN »| =

Front end 10. Report 1.

@ N

True / False

Records in table can be added, changed or deleted in Datasheet view and in a form.
Forms help the user to interact with databases without any technical knowledge.
Ms Access provides 6 types of forms.

Reports are generated for printing purpose. -

A report based on a querv always contains every record in the underlying tab]e
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Reports are used on computer screen only.

Report Wizard is the easiest technique for creating reports.

Report may contain data from table or query.

When a form is closed, the records entered in the form are automatically saved in the
database.

10. We cannot change any record of a table in a database using a form.

11. A form within another form is known as tabular form.

12. The options for layout of report are Columnar, Tabular and Justified.
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